Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,714
Community Members
 
Community Events
176
Community Groups

Issue with running bamboo shell task in docker

Edited

When I run job with task in docker it fails with 

8 time="2019-07-02T11:28:18Z" level=fatal msg="Error: Path not specified"
02-Jul-2019 11:28:18 Exit code: 1, output: STDOUT: Beginning to execute external process for build 'kubo - helm - kubo-deployment-dev #9 (KUBO-HELM-KUB-9)'\n ... running command line: \n/usr/local/bin/docker cp /var/opt/bamboo/atlassian-bamboo-6.8.3/temp/initialiseDockerContainer.sh1625454798126877638.tmp 7d9f46fd-f667-4618-9501-92d8256e89da1474566:/tmp/initialiseContainer.sh\n ... in: /var/opt/bamboo-home/xml-data/build-dir/KUBO-HELM-KUB\nSTDERR: time="2019-07-02T11:28:18Z" level=fatal msg="Error: Path not specified"
02-Jul-2019 11:28:18 Failed to start docker container 7d9f46fd-f667-4618-9501-92d8256e89da1474566
02-Jul-2019 11:28:18 com.atlassian.bamboo.docker.DockerException: Error running Docker run command

 

There is no /var/opt/bamboo/atlassian-bamboo-6.8.3/temp/initialiseDockerContainer.sh1625454798126877638.tmp file, so I am not sure why it is try to copy it to container. 

1 answer

0 votes

Hi @ScottHough

I created a build with docker runner to check those messages. I got a message pretty similar to yours:

command 03-Jul-2019 15:52:50 Beginning to execute external process for build 'Docker runner - Ubuntu test - Default Job #1 (DR-UT-JOB1-1)'
... running command line:
/usr/local/bin/docker cp /Users/dsantos/atlassian/bamboo/6.8.1/install/temp/initialiseDockerContainer.sh1545199765671114425.tmp 58fdafe6-6355-4546-978d-91dd4db030b412910596:/tmp/initialiseContainer.sh
... in: /Users/dsantos/atlassian/bamboo/6.8.1/home/xml-data/build-dir/DR-UT-JOB1

The file initialiseDockerContainer.sh<HASH>.tmp is created by Bamboo and deployed to the container as part of the initialization process. It is possible that the Bamboo server was not able to create this file for some reason or even that this file was deleted right after the issue to deploy it.

I have some questions that I believe will help us to investigate this further:

  1. I see this happened in KUBO-HELM-KUB-9. Is it correct to assume that prior builds were running as expected with docker runner?
  2. Were you trying to rerun a build when this problem happened?
  3. Are you able to reproduce the issue?
  4. Is this happening with other builds/plans using the same docker image?
  5. Have you checked if the permissions for the folder /var/opt/bamboo/atlassian-bamboo-6.8.3/temp/ were recently changed or even if your Bamboo server is running with a different user?

I'll wait for the insights you have when checking those questions.

1.  Every builds running with docker agent failed with this error.

2. Yes. It failed again.

3. Yes.

4. yes

5. permissions wasn't changed.

I have deployed bamboo server on ubuntu 14.04 ... so docker 

██docker -v
Docker version 1.6.2, build 7c8fca2

I am not sure what is the root cause. I have deployed one more vm, with ubuntu 18.04 and added this vm as remote agent with docker support. Now it works.

I don't have much time to investigate this further  ...

Hi @ScottHough

No problem man! Thank you very much for taking the time to follow up on my last message I appreciate that.

Let's leave this one to investigate in case it happens again or with another user.
Have a good one!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events