Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Invalid username when adding a Repository in Bamboo Edited

Hi, I'm trying to modify or add a new repository to our bamboo plan.  This has worked for us for a very long time.  Today when I try to do it, it comes back with "Invalid username" when I try to save the repository.

I believe this same user name is used to retrieve the list of branches in the repo on the same screen.  This works well and even displays the newly created branches. 

But when I click "Save Repository" I get an "Invalid username." error.  Due to this error I can't add or modify our plan's repo so this is a major issue.  I have admin access to the repo and my account is also fine (I can log in fine, I am not locked out).

Can you please let me know how I can add/modify repos? Is this a temporary downtime issue on Bitbucket?

Please note that using Linked Repos as suggested here https://community.atlassian.com/t5/Bamboo-questions/issue-with-adding-cloud-bitbucket-repository-to-build-plan-on/qaq-p/1097341, also fails.

 

Regards,


Sean

2 answers

Hi, updating Git for windows fixed this issue.

Hello @Sean Peters

We are still doing efforts on this issue and I wanted to double check your resolution, while making sure that other people that came across this post will not be mislead:

  • You have tried to use Linked Repositories with Git (not using the Bitbucket Cloud option)
  • It didn't work due an old version of git
  • You've updated your Git
  • Another attempt of using the Linked repository with Git (again, not with the Bitbucket Cloud option)
  • It worked!

If instead, you were still trying to use Bitbucket Cloud and now it is working, it is due a temporary change that is up on Bitbucket Cloud that temporary fixes Bamboo issues, but will be rolled back in the next days :)

Hi Victor, we are experiencing the same issue as Sean.  For about a week now we have not been able to create or modify repos in Bamboo due to this issue.  We do use Bitbucket Cloud.

Loading the repositories list works, but on Save or Test Connection we get "Invalid username" and "We couldn't connect to the repository. The details you provided were invalid."

What is the status of the temporary change?  Will there be a permanent fix?  We are running Bamboo 6.7.1.

Hello @Colin Cuthbert 

This issue with Bitbucket Cloud is fixed now on the versions 6.8.3 and 6.9.1. The Bitbucket Cloud rolled back the changes and if you are on older versions of Bamboo, you will not be able to use the repository type "Bitbucket Cloud". You can find more details in BAM-20455.

Like Colin Cuthbert likes this
Like Victor Debone likes this

And appears to be broken in 6.10. Any ideas?

I'm using 6.9.2 and have the same issue.

Like Prabhu Mani likes this

I'm using 7.0.3 and I have the same issue

Hey,

I just updated my Git to the latest git git-update-for-windows

I have also updated my Bamboo instance from 6.9.1 to 7.0.4

I am still getting this same issue. As everyone is stating, all of my existing repo connection works and I can create plan branches and stuff. But whenever I try to create link a new repo for a specific plan or create a global linked repo, it continues to say my username is invalid.

In my logs I see I am getting back a 404

2020-05-21 11:37:36,750 WARN [http-nio-8085-exec-3] [RESTCall] Response from GET https://api.bitbucket.org/2.0/workspaces/nick.ayala@martinmarietta.com/ (404)
2020-05-21 11:37:36,969 WARN [http-nio-8085-exec-3] [RESTCall] Response from GET https://api.bitbucket.org/2.0/users/nick.ayala@martinmarietta.com/ (404)
2020-05-21 11:37:37,157 WARN [http-nio-8085-exec-3] [RESTCall] Response from GET https://api.bitbucket.org/2.0/teams/nick.ayala@martinmarietta.com/ (404)

 

I even modified the permissions to the temp folder which I saw worked for someone. This is MAJOR because essentially I will not be able to create a new build for a new repo or project. 

We've started selecting git repo. Not bitbucket. You have to enter url and branch manually, but it works.

Hey,

So after posting my comment I found this workaround / fix for versions 6.8+ and it now works to select Bitbucket Cloud.

BAM-20900

I am running windows and using version 7.0.4 and I added  

-Dbamboo.bitbucket.cloud.use.workspace.api=true

to my system properties (java options)

For version 6.8 and 6.9 you will need to do something else. Just follow the issue I linked and it will explain everything for you.

 

I hope this helps everyone!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

220 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you