Installing Older Version of Atlas-SDK on OSX

I'm looking at doing some plugin development on an older version of Bamboo (5.6). As I found out in another post -- Bamboo 5.6 will NOT work with Java 1.8.

No problem, I installed Java 7 along side 8 on my Mac.  

The issue that I'm encoutering now, is that the current version of the SDK explicitly seems to require Java 8.

[ERROR] API incompatibility: org.codehaus.plexus.component.repository.exception.ComponentLookupException: com/atlassian/maven/plugins/ampsdispatcher/AmpsDispatcherRunMojo : Unsupported major.minor version 52.0

So the question is how to I install an older version of the SDK that doesn't require 1.8?

Note that using *brew search* i've been unable to identify older versions to download and install.


1 answer

1 accepted

This widget could not be displayed.

Try running 

brew tap atlassian/tap
brew search atlassian-plugin-sdk
brew install atlassian/tap/atlassian-plugin-sdk4 or
brew install atlassian/tap/atlassian-plugin-sdk5

Screen Shot 2017-04-20 at 19.21.26.png


Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

54 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you