Installing Older Version of Atlas-SDK on OSX

I'm looking at doing some plugin development on an older version of Bamboo (5.6). As I found out in another post -- Bamboo 5.6 will NOT work with Java 1.8.

https://community.atlassian.com/t5/Bamboo-questions/Atlas-run-AnnotationAwareAspectJAutoProxyCreator-is-only/

No problem, I installed Java 7 along side 8 on my Mac.  

The issue that I'm encoutering now, is that the current version of the SDK explicitly seems to require Java 8.

[ERROR] API incompatibility: org.codehaus.plexus.component.repository.exception.ComponentLookupException: com/atlassian/maven/plugins/ampsdispatcher/AmpsDispatcherRunMojo : Unsupported major.minor version 52.0

So the question is how to I install an older version of the SDK that doesn't require 1.8?

Note that using *brew search* i've been unable to identify older versions to download and install.

 

1 answer

1 accepted

Try running 

brew tap atlassian/tap
brew search atlassian-plugin-sdk
brew install atlassian/tap/atlassian-plugin-sdk4 or
brew install atlassian/tap/atlassian-plugin-sdk5

Screen Shot 2017-04-20 at 19.21.26.png

 

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot