How to safely restart Bamboo Service using command prompt from windows machine ?

I have installed Bamboo and Bitbucket in Windows machine and I have integrated both tool. I didn't install bamboo windows service in my system. I want to restart bamboo service using command prompt. Can you tell me how to restart bamboo service using command prompt and what is the startup parameter required ? 

2 answers

This widget could not be displayed.

Have you tried:

net stop bamboo & net start bamboo

 

-Lars

Thanks for your reply

I didn't try this command but I need more details for executing this command.

Do you want to execute this command from bamboo bin folder path or any other folder path?

Is it required Bamboo admin group access for executing this comman ? or Can I run this command from any other user ? 

Shall I close the command prompt after starting bamboo service ? Or it should be running continuously ? 

 

 

Poovaraj

You can run theese commands from "anywhere" on the cmd. The cmd needs to be elevated (admin)

 

-Lars 

Is it Windows admin access or Bamboo admin group access ?

Poovaraj

I have tried below command but it is not working. it is showing below error message

net start bamboo

Error message from command prompt

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

This widget could not be displayed.

Open services.msc and find the name of your bamboo service.

In our lab the name of the bamboo service is bamboo 

I didn't install bamboo windows service in my system, so it is not displayed in services.msc list.  Can you tell me how to start bamboo service without using windows service ?

Either execute InstallAsService.bat to install the Bamboo service, or run:

C:\Program Files\Bamboo>StartBamboo.bat

Option 1

Bamboo service is displayed in services.msc list after executing InstallAsService.bat file but I am unable to start bamboo service from services.msc list. it is showing below error message after starting bamboo service.

Error message :

Bamboo Service Error Message.JPG

 

Option 2 

I have executed StartBamboo.bat file from command prompt but it is showing below error message. 

Error message:

The Atlassian Bamboo Bamboo service is starting.
The Atlassian Bamboo Bamboo service could not be started.

A service specific error occurred: 1.

More help is available by typing NET HELPMSG 3547.

Press any key to continue . . .

 

 

 

What does the log say? 

How to check the log file ?

It should be just where you installed bamboo. 

I have restarted the service successfully but it is showing below error while login into bamboo.

Stack Trace:

io.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.IllegalArgumentException: Unknown cipher data id 0
 at io.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:156)
 at io.atlassian.util.concurrent.LazyReference.get(LazyReference.java:116)
 at com.atlassian.bamboo.plan.cache.AbstractImmutableChain.getPlanRepositoryDefinitions(AbstractImmutableChain.java:231)
 at com.atlassian.bamboo.plan.PlanHelper.getPlanRepositoryDefinitions(PlanHelper.java:49)
 at com.atlassian.bamboo.plan.PlanHelper.getDefaultPlanRepositoryDefinition(PlanHelper.java:69)
 at com.atlassian.bamboo.plan.branch.ChainBranchUtils.getANameFromBranch(ChainBranchUtils.java:64)

I am unable to login into bamboo tool after done below setting. It is showing "You have entered an invalid username and password. Please try again." error message

I am able to see the bamboo dashboard without login into bamboo and it is automatically triggering the job after push the code to bitbucket tool.  

Could you please let me know how to fix login issue ? 

Setting:-

https://confluence.atlassian.com/bamkb/unknown-cipher-data-id-0-when-performing-certain-actions-in-bamboo-on-windows-after-switching-bamboo-to-run-as-a-service-923437107.html?_ga=2.144353777.536993601.1504604520-1106767698.1504499190

Did you try wht is suggested under Resolution?

You`ll need to restart Bamboo after making that change.

You should also be able to start bamboo manually until you get this fixed, by executing the startup.bat file

Yes. I have tried above option under Resolution and I have re-started the services after making the change.

Now, I am able to login in default user name and password but I am unable to login using Activity Directory credentitals.  

Earlier, I have used to login using Activity Directory credentitals. Why is not working Activity Directory credentitals after making the changes ?

How to configure bamboo and Activity Directory ?

https://confluence.atlassian.com/bamboo/integrating-bamboo-with-ldap-289277210.html

Please note that once LDAP has been enabled, reverting back to local user management is not possible.

Thank you for the your quick reply and support 

Poovaraj

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

121 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you