How to make Bamboo to launch command prompts in foreground

My PowerShell script/ Batch script given as a Bamboo task in my plan is always launched in background in the Agent machine. 

Is there any setting in Bamboo , to mark my scripts to be always launched in foreground?

1 answer

2 votes

Hi Umai,

 

There is this parameter "wrapper.ntservice.interactive" in <agent-home-directory>/conf/wrapper.conf" file which can be set to true to  make things interactive.

 

But, could you share the requirement in detail here as what exactly this script task is supposed to do here?

 

Thanks,

Hi Robhit,

Thanks for the reply . I'm yet to try out the solution you have suggested.

My requirement in detail is ,in CI/CD environment I'm trying to run my testcases triggered from Bamboo. For this, I have to launch my selenium grid in a command prompt, then launch Appium server in a separate command prompt. After that will launch my test code via maven commandline. I will have to see the status of all these three components when my code is running. 

Currently, since Bamboo launches all the three processes in bckground, I'm not able to see the status of my tests, whether it has initialized correctly or if not, then what error has been thrown by Appium server or Selenium Grid etc..

Hope the solution above will help solving this problem. 

Thanks,

Umai

Hi Umai,

 

How are the agents running? are they running using the system account and you are logged-in as a different account? can this be a reason behind things running in the background and you can't see them?

Agent is running as a Service in "Local System account."

I have logged in as a different administrator user. Not sure if that is the reason. How to make Bamboo run in currently logged in user? I have installed Bamboo agent from the currently logged in user only, using the following command

java -jar atlassian-bamboo-agent-installer-5.15.5-SNAPSHOT.jar http://bamboo-host-serve/agentServer 

 For now, I have enabled 'Allow service to interact with desktop ' option in the Services->Logon tab. So I'm able to see my tasks in a separate window. This could be a temporary solution.

And making wrapper.ntservice.interactive option to true, doesn't work.

Thanks.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

29 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you