Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I specify JRE when creating a sidekick agent for per-build-container plug-in?

Trying to get the sidekick image built and having some issues.  Is there any documentation other than the README.md file?

My current problem is with getting the JRE requirement working but there are others.  The page says "download Oracle JRE and place it inside the working directory. Optionally if you have a company wide distribution url, use that one at a later step." and the help says "Java (JRE) download url or path inside working directory".  Have not been able to get this to work.

1.  I went to the JRE link provided and was presented with options to download a rpm file or a tar.gz file.  Which is expected (was unable to get either one working)?

2.  It says to place the file in the "working directory" but not sure where exactly.  Tried in sidekick folder and in sidekick/jre both without success no matter what I used after the -j command.  Is this just the path or should the filename be included as well?  Can I get an example?

3.  I'm running this script using my login but noticed the output folder is being created with root user and group.  I see no indication that this should be run with sudo.  What is the correct way to run this script?

4.  Using debug, I see the function "download if not cached".  Can I save these files (JRE, Bamboo jar file, etc.) somewhere so I don't have to worry about downloading them?  If so, where should they go?  Looks like I might have a problem with the wget to d/l the jar file so would like to just be able to place all these in a folder and be done with it.

1 answer

1 accepted

It looks like the major problem is the script didn't clean up after itself if it fails. I believe the first time it failed caused the subsequent issues as the output folder was already there. Removing this directory between each attempt help.

As for the -j JRE option, I manually downloaded the JRE and placed in a folder called per-build-container/sidekick/stuff/. For the command line it is not just the path but the file name as well (the tar.gz and not the RPM). For my case it was

-j stuff/jre-8u251-linux-x64.tar.gz

Note I also ran the script as sudo. Wasn't stated but seemed to work OK.

Another issue I ran into was the download of the agent jar file. There is a redirect in the wget file that was not working for us. I ended up editing the script and replacing the Altassian based url with the redirected one.

This addresses all the issues I ran into with the initial question.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center is here!

G’day Bamboo customers, The wait is over! Bamboo Data Center edition you have been asking for is finally here! This self-managed enterprise offering of Bamboo has the resilience, reliability, and s...

502 views 1 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you