Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,836
Community Members
 
Community Events
168
Community Groups

How do I add git capability to agent for Per Build Container builds?

We are working to get our Bamboo builds running in a K8s cluster.  We have the PBC plugins installed and configured, sidekick image created and our test plan seemS to be running OK (within OpenShift) but when the Source Code Checkout task executes, getting our source code from Bitbucket, I see the message "Submodules handling requested but no native Git capability defined for agent. Please define native Git capability for agent to use submodules." in the log file.

I've created a new sidekick image adding:

/buildeng/bamboo-update-capability "system.builder.command.Git" "/usr/bin/git"

to the file setup.sh and added:

Add setup.sh /buildeng-custom/

to the Dockerfile

I then ran the container locally via docker run and verified that the file and contents were there and in the correct location.

docker run --rm -it bamboo-agent-sidekick
# cat buildeng-custom/setup.sh
# GIT capability
/buildeng/bamboo-update-capability "system.builder.command.Git" "/usr/bin/git"

When I re-run the job I'm still getting the same error.

Can someone tell me how configure the system this so that I can do submodule updates?

Thanks






 

2 answers

1 accepted

2 votes
Answer accepted
Duke Atlassian Team Jul 02, 2020

I am not sure about "system.builder.command.Git". Have you tried "system.git.executable"?

/buildeng/bamboo-update-capability "system.git.executable" "/usr/bin/git"

See Submodules handling requested but no native Git capability defined for agent. Please define native Git capability for agent to use submodules for more details.

Thanks.  That seemed to get one step further.  Now getting "Permission denied (publickey)".  We are using linked libraries and I have tried saving the repository configuration to refresh the authentication details multiple times as well as putting the access key into Bitbucket manually without avail.

Any thoughts?

Duke Atlassian Team Jul 02, 2020

It's great that "system.git.executable" got you one step further. Now it looks like you hit the issue discussed in BAM-11369. I suggest trying the workaround in Permission denied (publickey) submodule after upgrade.

Can you please share your Helm chart? We may suggest for you some cloud-native recommendations (using initContainers, configmap,... instead of building image on top of the official image, ... so on) ?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 9.0 is now available

Hey there, Data Center community! I'm Martyna Wojtas and I am the Product Manager for Bamboo Data Center. I’m excited to share that Bamboo 9.0 is now available. We purpose-built this platform to help...

301 views 0 7
Read article

Atlassian Community Events