Git submodules using ssh on a remote agent

Hi,

I am having a problem with my submodules in bamboo. I'm using GIT. This is a Windows machine. I was able to get the submodules to work by adding my ssh key into the bamboo home directory, but I don't know if that same fix is supposed to work with an agent.

Has anyone been successful in cloning submodules using an remote agent?

1 answer

1 accepted

This widget could not be displayed.

Hi Chris,

I feel you are experiencing the issue reported at https://jira.atlassian.com/browse/BAM-11369 The available workaround are two folds:

# Use private key fro the repository that are not protected by passpharase

# Setting up each agent .ssh/config configuration manually to allow Remote Agent machines access your git repository via ssh (using private SSH keyfiles stored on those machines).

Try the options and lets know how it goes for you.

Regards,

Sultan

Hi Sultan,

My private keys do not have a passphrase.

As for the second point, I'm not sure where the Bamboo is looking to find the .ssh private key. I have a few on the Remote Agent. Is the path "%USERPROFILE%\.ssh"? Or is Bamboo looking in a different location?

Thanks,

Chris

Yes Bamboo is looking at the %USERPROFILE%\.ssh directory

Could you please provide an example of how my config should look like? I set mine up to as

*

IdentityFile C:\Users\{current user}\.ssh\id_rsa

That is where my private key is located. Although the submodules are still giving me a "permission denied" error.

Here is the error I get:

Warning: Permanently added '[StashURL:7999' (RSA) to the list of known hosts. Permission denied (publickey). fatal: Could not read from remote repository. Please make sure you have the correct access rights and the repository exists. Clone of 'ssh://git@StashURL:7999/sm/windows-common.git' into submodule path 'common' failed)

When I run the command in the command prompt, it clones the repo just fine.

I created a work around. I had a different machine checkout the code and this PC compile it. After a while, I accidentally forgot to set this new machine as a requirement and the checkout of the submodules worked.

Hi Chris,

Thanks alot for the feedback

Did you ever get to the bottom of where to locate the private key on the remote agent? I'm still trying to solve this problem.

You know. I never did, but i did find a solution for myself.

I'm not sure if it was my particular instance or just how bamboo handles submodules, but it kept looking for the ssh key in "$Git_repository/y/.ssh". I ended up just comitting "/y/.ssh/config" into my repository that pointing to the ssh key I wanted to use, then everything worked just fine.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

135 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you