Getting "Could not find war file at..." error, even though the path is right... what am I doing wrong?

This question is in reference to Atlassian Documentation: Using Tomcat with Bamboo for continuous deployment

I'm getting the "could not find war file at..." error. But the path it tells me it can't find the war at is the correct path to a file that I have verified does exist. Any ideas how to fix this?

1 answer

1 accepted

This widget could not be displayed.

One immediate thought - a lot of OS's say "can't find file", when they should say:

  • file is not there (you've checked that)
  • file has strange characters in the name that confuse it, so it's not there (unlikely, but I had to mention it.  Copy the path and file name and try an ls with the pasted string)
  • the account trying to read the file does not have the right permissions to do so

permissions issue. Thanks!

@Christopher Tas, when you changed permissions, was it on the user you specified for the Tomcat Manager account? Or somewhere else?

Thanks.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

160 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you