Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Getting an error while trying to add a bitbucket repo in bamboo server/stash

Usharani January 23, 2023

Hi I am new to Bamboo ,trying to create a plan and link a bitbucket repository to it but i am facing the below error while saving the repository

can someone pls help on this.



Could not check if existing access key is valid: java.lang.RuntimeException: Could not create file: C:\Program Files\Bamboo\temp\bamboo-ssh.8f69d965.bat


Bamboo error.png

3 answers

1 vote
Helen February 1, 2023

OK, I've solved this on my system! It's permission related. I turned on some debug level logging for Bamboo and found that there were log messages "unable to detect changes" and "git credentials storage exception".

My Bamboo service runs as an active directory user. Using Process Monitor I could see that there were differences in the processes run depending on whether Bamboo was run as the AD user, or as the local system account. Specifically, when Bamboo is run as the local system account, there were a stack of git.exe and sh.exe processes that weren't present when running as the AD user.

I had set up full control for Bamboo's AD user on both the Bamboo installation and home directories, *however* instead of giving the user permissions directly, I had added them to an AD group and provided permissions to the group. This was the source of the problem.

To fix the issue I added the AD user to the directories with full control (and removed the group). After restarting, Bamboo worked like a charm.

0 votes
Lee li February 17, 2023

Try to run Bamboo with administrator permissions.

0 votes
Helen January 31, 2023

I'm afraid I don't have any answers to offer, just wanted to say I'm encountering the same problem!

What's your set up like? I'm using Bamboo 8.2.5 and Bitbucket 7.21.3, and all my atlassian products are configured behind Apache, access via https.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events