Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Fatal error 'Unable to read cipher data for 0' when linking to BitBucket Server repo. Edited

Hi, when I attempt to link to a BitBucket Server repository with Bamboo 6.9.0 I get a fatal error 'Unable to read cipher data for 0'.

This is a brand-new install of Bamboo. It has been linked with our existing instance of BitBucket Server and the link has been configured on both instances. Each link shows a green 'connected' status.

Attempting to link a repository in the Admin console under Linked Repositories results in the same error:

browser_error.PNG

Bamboo version: 6.9.0 build 60909 running on CentOS 7.6.1810
BitBucket Server: v5.6.2 running on CentOS 7.4.1708

Log file extract:

```

2019-06-04 15:05:07,967 WARN [http-nio-8085-exec-22] [CacheAwareness] Inheriting disabledCaches:[com.atlassian.bamboo.ANY]
2019-06-04 15:05:08,544 FATAL [http-nio-8085-exec-22] [InstanceSecretStorage] Cipher initialisation vector is unavailable
2019-06-04 15:05:08,547 ERROR [http-nio-8085-exec-22] [BambooActionSupport] java.lang.IllegalArgumentException: Unable to read cipher data for 0
java.lang.IllegalArgumentException: Unable to read cipher data for 0
at com.atlassian.bamboo.crypto.instance.InstanceSecretStorage.readKeyAndIv(InstanceSecretStorage.java:59)
at com.atlassian.bamboo.crypto.instance.InstanceSecretStorage.getOrCreateCipherData(InstanceSecretStorage.java:108)
at com.atlassian.bamboo.crypto.instance.InstanceSecretStorage.getCipherData(InstanceSecretStorage.java:99)
at com.atlassian.bamboo.crypto.instance.InstanceSecretStorage.getKeyAndIv(InstanceSecretStorage.java:84)
at com.atlassian.bamboo.crypto.instance.InstanceCipherProvider.getKeyAndIv(InstanceCipherProvider.java:64)
at com.atlassian.bamboo.crypto.instance.InstanceCipherProvider.getCipher(InstanceCipherProvider.java:50)
at com.atlassian.bamboo.crypto.instance.InstanceCipherProvider.getEncryptor(InstanceCipherProvider.java:37)
at com.atlassian.bamboo.crypto.instance.SecretEncryptionServiceInternalImpl.encrypt(SecretEncryptionServiceInternalImpl.java:130)
at com.atlassian.bamboo.crypto.instance.SecretEncryptionServiceInternalImpl.encrypt(SecretEncryptionServiceInternalImpl.java:119)

```

Troubleshooting:

1. I am able to create a plan without linking to a repository.
2. I get the same error if I make myself administrator on both Bamboo and BitBucket.
3. Removing and recreating the link between Bamboo and BitBucket does not solve the issue.
4. Bamboo is running has the 'bamboo' user. This user has drwx access on the 'cipher' directory and rw access on the file cipher.key_0 inside that directory.
5. I've looked at the questions linked but they don't fix my issue:
https://community.atlassian.com/t5/Jira-Service-Desk-questions/not-able-to-link-repository-to-bamboo-Unable-to-read-cipher-data/qaq-p/1048092

6. I have *not* tried a reinstallation with a new home directory and database. If I'm unable to resolve here that's my next step.

 

1 answer

hi,

I get the same error while linking to a repository

[BambooActionSupport] java.lang.IllegalArgumentException: Unable to read cipher data for 0

 

Bamboo version 6.9.1 build 60910 (Centos 7)

Hey, I lodged a support request with Atlassian about my issue and they helped me through resolving it.

The issue was an incomplete key generation, and the solution was to remove the partially-generated key from both the database and the filesystem to force regeneration.

These are the steps to resolve I was provided (paraphrased):

 

The database should have two rows, the com.atlassian.restricted.instance.cipher.key_0 and com.atlassian.restricted.instance.cipher.iv_0. They can be selected with:

select * from BANDANA where BANDANA_KEY like '%cipher%';

To regenerate the cipher:

  1. Shutdown Bamboo.
  2. Remove the com.atlassian.restricted.instance.cipher.key_0 and/or com.atlassian.restricted.instance.cipher.iv_0 row from the database (found in the select query above).
  3. Remove the cipher directory (under <bamboo-home>/xml-data/configuration)
  4. Start Bamboo.
  5. Before configuring anything else, create a Repository first. This will re-generate the cipher.

Hope this helps!

Like Haythem Benizid likes this

We have the same issue. Question is how did this occur? And can it happen again.

Next step - to look to follow this and regenerate the cipher....

Foong Atlassian Team Sep 18, 2019

Do not use the suggestion to delete and regenerate the cipher key. It is suggested depending on certain situation. Using this suggestion might cause an even severe problem without solution at the end.

Report the issue to Atlassian Support so that the logs can be analysed and a different solution might be suggested.

... which we had and did. And spent 2 weeks troubleshooting with them. Watch out for a blog post soon on how to really do this - now Atlassian know from experience the possible variants!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

673 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you