Facing problem while linking Git repository with Bamboo

Hi,

I am going to link the Git project repository in Bamboo. I have installed Bamboo in the same server where Git exist. So both are in the same server now. After installing bamboo I have selected  "Link Repository" tab so that I can create the link with my Git Repository. To do this when I entered https://git_url/repository_name.git  as the Repository URL it shows the following error.

fatal: Unable to find remote helper for 'https'

So I think as both are running on the same server I tried to access this by using IP instead of URL, now I entered      git_server_ip:443/repository_name.git  as the Repository URL. Now it shows the following error.

Warning: Permanently added '[127.0.0.1]:56987' (RSA) to the list of known hosts.
BAMBOO-SSH-PROXY: [While connecting to [username@/git_server_ip:22]: Authenticating remote session failed]
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

If I entered git_server_ip:80/repository_name.git as the Repository URL it again shows the above mention error.

According to my Use Cases I need to link the Git Repository with Bamboo by using HTTPS authentication with a user name and password not using SSH.

 

Now I am sharing some information for your reference...

I am using Bamboo (V 5.10.2) and Git (V 2.6.0)

OS - CentOS 7.1

Git is running using Nginx and httpd was not installed.

 

Suggest me a possible way so that I can create the New Plan in Bamboo and link the Git Repository in it and authenticate this with HTTPS with a username and password , not using SSH.

Thanks in advance...

2 answers

0 votes

Hello, looks like original message you've got 

fatal: Unable to find remote helper for 'https'

is linked to your environment configuration. Please look at this discussion - http://stackoverflow.com/questions/8329485/git-clone-fatal-unable-to-find-remote-helper-for-https

To confirm it works for you, try to clone repo from command line like 

git clone https://git_url/repository_name.git

 

 

Hi,

Thanks for your suggestion.

But the problem is that I can access the URL via https, that means when I entered https://git.xyz.com in the browser I can access the portal with my user credential. That means https is accessible. But when I am going to link the Git project repository in Bamboo and paste the https repository url instead of  SSH url in the Repository URL field and provide the same user credential  it shows the above mentioned error. 

And by observing the error I think it forcefully authenticate the URL via SSH. So can you please suggest me if I am correct then how can I change the forceful SSH authentication, because I want HTTPS authentication by using username and password.

I have already installed the curl -devel and ldap certificate but can't uninstalled the git as it is running on the prod environment.  It is necessary to uninstall and then reinstall git after installing curl.?

I have also checked that if I installed bamboo in a diff server it also throwing the same error. for the test purpose I have install bamboo in a diff server and trying to access git over there . but it shows the same error

Hi. As I said problem is at git client. You can confirm it by cloning repo from command line at server where you installed Bamboo. Login there as user which you use to start Bamboo and try to execute from console

git clone https://git_host/repo.git

I believe you will get the same error as you see in Bamboo UI

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,064 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot