Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,897
Community Members
 
Community Events
176
Community Groups

Error "Unable to publish artifact:" but the artifact is there at the end

Norbert Rising Star Jun 13, 2022

Bamboo is running on a Windows server

If I run the job on the default agent (windows server)-> everything fine
If I run the same on the remote agent "Linux" everything works except I get an error

simple 13-Jun-2022 12:18:16 Publishing an artifact: stuff
error 13-Jun-2022 12:18:16 Unable to publish artifact [stuff]:
error 13-Jun-2022 12:18:16 The artifact is required, build will now fail.
simple 13-Jun-2022 12:18:16 Finished publishing of artifact Required shared artifact: [stuff], pattern: [**/*.py] in 278.1 ms

 

but the artefact "Stuff" is there, even on the Linux build and it looks ok...

The only way to disable the error is to disable the "Required" flag for the artefacts...
But I am quite confused why I get the error at all.

 

configuration of the artifact:artifact_config.png

 

 

 

1 answer

1 accepted

0 votes
Answer accepted
Norbert Rising Star Jun 15, 2022

Hello

found the problem

for this plan "custom artifact handler" was activated
The default publishing worked fined but somehow we (I) activated agent local publishing
with a windows folder which failed for the linux build.

 

IMHO this is a bug in Bamboo because you don't get any info on what is failing!

Obviously, it was a folder which was not accessible but without any feedback, I only stumbled over the solution through luck!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events