Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Error code 4 when starting Bamboo service on MS Server 2012

I'm trying to install Bamboo on a VM so that I can demo it to a customer.

I have downloaded the 32 bit installer and run it successfully. I am trying to start the Bamboo service and I'm getting the following Windows error:

Windows could not start the Bamboo on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service specific error code 4.

What does error code 4 mean? Can anyone offer any advice to help me get up and running?

Event viewer tells us:

The Bamboo service terminated with the following service-specific error:

The system cannot open the file.

Details:

-<System>
<ProviderName="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
<EventID Qualifiers="49152">7024</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreatedSystemTime="2014-01-03T15:56:18.468223600Z" />
<EventRecordID>63839</EventRecordID>
<Correlation/>
<ExecutionProcessID="604" ThreadID="4940" />
<Channel>System</Channel>
<Computer>AY-DemoVM</Computer>
<Security/>
</System>
-<EventData>
<Data Name="param1">Bamboo</Data>
<Data Name="param2">%%4</Data>
<Binary>420061006D0062006F006F000000</Binary>
</EventData>
</Event>
UPDATE: Still not working and I have opened support ticket BSP-12380. Still waiting on a response and I have a deadline to get this working by the end of tomorrow. I would really appreciate some assistance.
UPDATE: So I fixed my Java path variable (which was the first problem) and I can get it running from the console, but it would be much more prefereble to have it running as a service. When I try running StartBamboo.bat as Administrator I get the same error from the console. And before you ask, having checked what the standard error code 4 means, I hardly have any windows open. :-)

4 answers

1 accepted

15 votes
Answer accepted

I fixed my issue by using an administrative command prompt to uninstall then reinstall the service. Using a login credential that has administrative permissions didn't help.

It worked for me, Running "installService.bat" as an administrator wasn't enough.

Had same issue on Windows Server 2008 R2. One thing I noticed is that when I reinstalled using elevated command prompt, the service name changed from "Bamboo" to "Apache Tomcat Bamboo"

I'm running into the same issue. I can't seem to see the ticket you opened. I installed the 64 bit version on ms server 2012 and have jdk 1.7 installed. I can run the start batch file, but I get the same error when I try to start the service.

Hi.

I have a similar problem and I am currently evaluating this product along with other suite of Atlassian products for my company. I need help because I have limited time to setup and evaluate the product for the team. So far, it is Bamboo that I have problem setting up with.

As a test server, I have Windows Server 2008 R2 x64 installed. I have,

  • JIRA x32 (running on its own VM)
  • Stash x32 (using JAVA_HOME path)
  • Crucible/FishEye x64 (running on its own VM)
  • jdk-7u75-windows-i586 installed on c:\java\jdk1.7.0_75
  • On the system environment variable, JAVA_HOME is c:\java\jdk1.7.0_75
  • System's path=%path%;%JAVA_HOME%\bin
  • Firewall 8085 is enabled

Now, because of the unusual setup on the same test server (other than having to redo them again i.e. making all x64), I am deciding on using Bamboo x32 since it uses same JAVA_HOME and Stash maps to it via install. Stash works with the JDK because I can stop and start Stash and it runs fine. All other products also running fine.

Situation 1: After installing Bamboo, I decided to start it as a service so it could start up with the machine. When I went to Start/Programs/Bamboo/Install Service, I got the prompt to run as Admin and I clicked Yes. It popped up a series of prompts in which I clicked Yes that Tomcat did something. After that, I could see Bamboo at Services and it showed Stopped. When I went to services.msc, I could see Bamboo as a service and it showed stopped. I tried to start it and got the message:

Windows could not start the Bamboo on Local Computer. FOr more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 4.

Clicking start service on the Services tab on task manager shows

Title: Unable to Start Service

Message: The operation could not be completed. Access is denied.

 

Event viewer shows:

The Bamboo service terminated with service-specific error. The system cannot open the file ...

Details shows:

- System

- Provider

[ Name] Service Control Manager
[ Guid] {555908d1-a6d7-4695-8e1e-26931d2012f4}
[ EventSourceName] Service Control Manager

- EventID 7024

[ Qualifiers] 49152

Version 0

Level 2

Task 0

Opcode 0

Keywords 0x8080000000000000

- TimeCreated

[ SystemTime] 2015-02-04T19:25:33.520876400Z

EventRecordID 16197

Correlation

- Execution

[ ProcessID] 524
[ ThreadID] 5812

Channel System

Computer servername.com

Security

- EventData

param1 Bamboo
param2 %%4

 

Situation 2: If I went to Install Service as Run as Administrator via Explorer, it ran and nothing got registered in the services.msc console. If I opened a command prompt as an admin and ran InstallAsService.bat after that, it showed The specified service already exists. Failed to install serviceFailed installing 'Bamboo' service.

Typing UninstallService.bat showed The service 'Bamboo' has been removed. Typing InstallAsService.bat installed the service with it not shown in services.msc and uninstalling it removed the service.

 

The above also happens with standalone Win7 x64 with only 32 bit JDK 1.7 and also x32 Bamboo.

 

Could anyone please shed light for me? Thanks.

I figured out my problem. In either case e.g. bamboo32 with jdk32 or bamboo64 with jdk64, I will need to start-up an administrator command prompt and go to the binary folder for bamboo e.g. c:\atlassian\bamboo\bin and type service install to install bamboo as a service. This works! I am using Bamboo 5.7.2 and JDK 1.7.0_75. Hope this helps others too! Weird thing is that with this method, the naming convention is consistent to other Atlassian products e.g. i.e. description name is Atlassian Bamboo rather than Bamboo. Same as on the services tab on task manager.

1) Run UninstallService.bat as Administrator. 2) Run InstallAsService.bat as Administrator. 3) Run StartBamboo.bat.

Thanks all for the heads-up on the service stuff.

I had a similar issue after a Windows update (and or Java update), but the error code was "1".  I had to change the environment variable for JRE_HOME and then had to delete the existing service (use the Bamboo "service" bat file in the "bin" folder) and then re-add it using the same bat file.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

696 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you