Hi, I use bamboo server and with the last 9.4, I'd like to use the ephemeral agent concept.
My bamboo test server is running on a VM Debian 10 (only terminal)
Following documentation (cf. https://confluence.atlassian.com/bamboo/enabling-ephemeral-agent-support-1236444140.html), I tried to configure access to my k8s cluster :
* adding kubectl on my bamboo server (VM debian) => ok
* adding my config file under [my install]/server/shared => ok
* configuring access to the config file in bamboo administration screen => not ok
Our cluster access is manager with OIDC (keycloack) and Iv'e got this error message :
error: unknown command "oidc-login" for "kubectl" Unable to connect to the server: getting credentials: exec: executable kubectl failed with exit code 1
How can I configure bamboo to pass oidc authentication ?