Enabling Bamboo gatekeeper merge fails

I am trying to use the Gatekeeper feature in Bamboo but currently, it fails with some weird exception:

MeregeCommand Error:

com.atlassian.bamboo.plugins.git.GitCommnadException: command /usr/bin/git remote set-url origin file:-----/_git-repositories-cache/-----failed with code 128. Working directory was []...stderr: fatal: Not a git repository(or anyof the parent directories): .git 

 

1 answer

0 vote

Hi Alok,

I would first run a git status on the repo to make sure you don't get the same error there.  If so verify the existence of a ./git folder in the repo's folder.

If that is good, the repo cache may be corrupted but we would need more of the log to determine what is going on.  If you can provide a a larger block before and after that error we'll be able to make a better determination as to what is going on.

Cheers,

Branden

Thanks, Brenden! I got to know that Bamboo uses repository caching where the code is first fetched from source control to a local cache(on the bamboo server). So auto merging fails even before it runs any task on an agent(like running git status).  

There is a high probability that the local cache is corrupted(speculating as I don't have admin access). But the interesting thing is all the branches works fine when "Auto merge " is disabled. 

I manually deleted the cache directory and it still gives the same error.

Hi Alok,

Thanks for the update.  Can you provide the code block before and after the error you see?  You should be able to attach a text output and if you need to you can remove some of the identifying data and we'll go from there.

Thanks,

Branden

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,094 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot