Email won't send after upgrading to Bamboo 5.10.3

We recently upgraded from Bamboo 5.9.1 to 5.10.3.  Since then we have not received any email notifications.  I checked the catalina.out file and found:

2016-04-11 11:48:24,095 ERROR [http-nio-8085-exec-23] [EmailService] Failed to send email

com.atlassian.mail.MailException: javax.mail.AuthenticationFailedException: No authentication mechanisms supported by both server and client
at com.atlassian.mail.server.impl.SMTPMailServerImpl.sendWithMessageId(SMTPMailServerImpl.java:214)
at com.atlassian.mail.server.impl.SMTPMailServerImpl.send(SMTPMailServerImpl.java:151)
at com.atlassian.bamboo.mail.EmailService.sendEmailSynchronously(EmailService.java:137)
at com.atlassian.bamboo.mail.BambooMailer.send(BambooMailer.java:84)
at com.atlassian.bamboo.ww2.actions.admin.mail.ConfigureMailServer.testSMTPServer(ConfigureMailServer.java:190)
at com.atlassian.bamboo.ww2.actions.admin.mail.ConfigureMailServer.doEdit(ConfigureMailServer.java:133)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)

...etc...

The Stash server which is on the same host is still successfully sending emails.

I have tried No TSL, TSL, no password, password, etc. all to no avail.

7 answers

1 accepted

In our case we had cleared the username and password used to connect to the SMTP server so that we would use anonymous SMTP connections.  But it seems that to get this to take effect, Bamboo itself has to be restarted.

0 vote

Create support request at support.atlassian.com to get help from our support engineers

Just found that atlassian-bamboo-5.9.1/atlassian-bamboo/WEB-INF/lib/mail-1.4.1.jar exists but atlassian-bamboo-5.10.3/atlassian-bamboo/WEB-INF/lib/mail-1.4.1.jar does not (nor any other version of the same).

Tried copying it in pace - but to no avail.

0 vote

Presence of a JAR is not an issue here. Bamboo-5.10.3 uses more recent version of javax.mail package and JAR file is now located in WEB-INF/lib/javax.mail-1.5.2.jar 

Is there any solution to it? We liked to have email notifications

0 vote

@Boris Alyurov, please create support request at support.atlassian.com. 

JavaMail was updated in Bamboo 5.10.3 from 2.4.1 to 2.5.12 and some clients had issues with Microsoft Exchange server access. Our support engineers will help you

This is resolved now. We change the email configuration to use TLS. It would have been great if this gotcha issue was documented in the release note. 

Thanks

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot