Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Does anybody know why the Trigger I set are being removed by the System?

 

I have set scheduled triggers on my deployment project, however every month(seems like a random day)  it seems the triggers are being removed

After checking the Audit logs

The Triggers are being removed by the SYSTEM

 

Do you have an idea why this is happening?Capture.PNG

1 answer

0 votes

Hi @Joel_Enriquez,

That's really weird. Two hints here.

  1. If you open <Bamboo home directory>/logs/atlassian-bamboo.log, so your Bamboo Server log and grep for either "Trigger has been removed"or anything with "trigger" or "removed", can you match that with an error or an exception? If so, you might want to google for this error / exception and see where it points you to. Possibly that guides a way to solve this issue out.
  2. Since the origin of this "trigger removal" is called out to be SYSTEM, if you check your system logs for the dates and times of the Audit log, what does that tell you?

As the incidence is seemingly SYSTEM triggered, I would not expect you to find a lot per step (1) from above. Even though, it's a chance and thus worth trying.

Finding something in the system logs, I'd regard as much more realistic. And as root of this issue, I could just think of any process on your Bamboo host that, for whatever reason, provokes that accidentially.

Another viable question is always this: Since when do you see this happeneing and what you made just before the first time that you saw it? That might have been some Bamboo-, system- or possibly network-wise change and it might get you more ideas of what to look into.

Hope that I could be of some help. For any further assistance that you'd like, merely get back to your Community per this thread.

Thanks a lot, Gerhard

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.2 is here!

I'm happy to announce that Bamboo 7.2 has been released and it’s overflowing with awesome new features. This will be the last major Server release before the launch of Bamboo DC. Bamboo logs We...

555 views 6 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you