Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,029
Community Members
 
Community Events
176
Community Groups

Disable build for master branch

I've got two build plans for the same repository, an app:

1. Build & Deploy when commit to master

2. Build & Test when commit to feature/.*

 

The problem for me is that BOTH plans run when I commit to master, is there a way for me to disable the plan for master on the second build plan?

I tried adding master as a "plan branch" and set it to not enabled, but that didn't help, it built it anyways.

Suggestions? Running bamboo version 5.14.

1 answer

1 vote

I assume your 'master' plan of the 2nd build is configured to build 'master' branch of the repository, right?

If that's the case simply go to plan details of the 'master' plan and disable the plan. This is counter-intuitive, but all it does is it disables building of the 'master' plan but it doesn't not disable the plan branches. The branch detection will continue to work and branches will be built. But the 'master' plan won't.

It does detect the new branch, but since "master" is the branch parent, the newly created feature branches are disabled by default and not automatically enabled.

 

Have a look at the attached screenshot. It says that the entire plan is disabled, therefore the automatically detected branches will also be disabled.

Is there a way to fix that?

Screen Shot 2018-04-12 at 11.05.28 AM.png

Like Edward_Burns likes this

Another way to accomplish this, in theory, would be to change the base branch of the plan to something other than 'master'.  @Marcin Gardias is there a way to change the base branch of a plan?  I am very curious...

Like Edward_Burns likes this

Disabling the Master plan will not impact the creation of branch planes. The plan is created and executed (first build for this plan). But it actually does nothing if the parent plan is disabled.

I tried adding the master branch as a branch plan and disabling it but this does not work. 

@Marcin Gardias the bug mentioned may have fixed the branch creation, but it didn't fix the execution.

edit: seems to work most of the time, couldn't find why sometimes it does not run the maven task

Like Edward_Burns likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events