Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Configuration Wizard Hangs when creating the database for version 7.2.4

I am trying to install Bamboo 7.2.4 using MySQL 5.7.34. This is a new install and new database and thus I am using the configuration wizard to setup. I get to the stage where the wizard is asking to configure the database. Unfortunately, the setup just hangs.

It creates the database, but it gets hung and cannot move to the next stage of the step up.

Help!!

1 answer

Hi Jason,

Check the database is configured correctly. Incorrect collation, BD user permissions, etc can cause some weird stuff to happen. Cheers!

Joshua, 

I definitely made sure that the DB is configured as mentioned with the proper character set ( utf8 ) and the proper collation ( utf8_bin). I have created a bamboo user with the proper privileges. 

However when I run I am "root" and not bamboo user. 

Any thoughts on being a using the dedicated user to run?

Hi Jason,

It is possible that the setup is not hanging on DB population, but on home directory population and the user may play a part of it.

  • Are you tailing application logs during setup? There should be a clear delineation between the DB setup and whatever follows it. It may also be worthwhile to check/tail the DB logs to see if Bamboo is still working the DB or if it actually dies.
  • How is Bamboo being started? Is Bamboo setup as a service or did you setup systemd? (here's the windows service page if needed)
  • During installation, did you set the home directory and is it's permissions/ownership correct?
  • Have you checked the catalina log to see if an error appears? The app log should also be in catalina, but additional tomcat stuff will be in there too.

Cheers!

Johsua,

Indeed I have Bamboo set up as a service using systemd. 

I have created a dedicated user that has the required permissions and tried running as that dedicated user. 

 

I have checked the logs and it does not give me an explicit ERROR  that points me in any direction.

Everytime I try and set up I do the following,

external DB > MYSQL > Direct JDC connection > Provide privileged DB user to create DB > it then tells me that it is setting up the DB and just hangs there for hours telling me it is creating the DB

Jason,
Does it finish? What does the end of the hang look like? Is it an error? Do you see tables being created/populated in the DB? The piece of information that will make all this make sense is still missing. No, I do not know exactly what it is. Yes, you have to find it. Please let us know what is under those rocks. Cheers!

Joshua,

The install does not finish so no error code is shown. The database indeed gets created because when I enter the command show tables; there are tables.

The logs seem to stop at,

60601: Validate existing Atlassian User directories for Embedded Crowd migration

Hi Jason,

That appears to be an upgrade task and not an install procedure. Are you connecting Bamboo to Jira or LDAP for user management?

There may be an issue with the atlassian-user.xml file: either it contains data it should not or it does not contain data it should. Cheers!

Suggest an answer

Log in or Sign up to
This widget could not be displayed.
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center is here!

G’day Bamboo customers, The wait is over! Bamboo Data Center edition you have been asking for is finally here! This self-managed enterprise offering of Bamboo has the resilience, reliability, and s...

425 views 0 17
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you