Change bamboo agent username

I have a trouble in changing the Bamboo agent username. Could anyone help with this. 

2 answers

1 accepted

This widget could not be displayed.

ba.PNGThe agent that is working as of now looks like this and in wrapper.conf I have changed the directory structure in -Dbamboo.home=/data/atlassian1/bamboo-agent-home

and also in bamboo-agent.cfg for build working directory pointing to above one, these both look good when I deploy it is working as expected.  But when I see the buildkey for checkout directory the owner and group both are root. As, my other agent checkout does with wasadmin. It should be same for this also. I checked out for new agent which shows the username as root.  Looks to me, if the username is changed, then this will checkout with wasadmin.b.PNG

Gonchik Tsymzhitov Community Champion Jan 09, 2018

May I know under which user have you installed the bamboo remote agent? 

I deleted and re-installed it, now the username is wasadmin. Thanks all. 

This widget could not be displayed.
Gonchik Tsymzhitov Community Champion Jan 09, 2018

Hello Surya, 

 

Could you clarify the your question? 

Do you want to change the username for run bamboo wrapper? 

If it is,  

1. let's check this thread for systemd

https://community.atlassian.com/t5/Bamboo-questions/How-to-I-install-bamboo-agent-as-a-daemon-under-Linux/qaq-p/393880

2. for init.d let's check the script in /etc/init.d/bamboo-agent

3. reg. for windows service. let's check in service run as.

 

Thanks

 

Cheers,

Gonchik Tsymzhitov

Hi Gonchik,

I have installed a remote agent, in which the username shows 'root'. I need to change the username (user home should be /home/wasadmin) and current running directory also. 

Current running directory: /data/atlassian1/bamboo-agent-home/bin

user home: /home/wasadmin

It should look like this. Please help

Bamboo path.PNG

Hello @Surya Banka,

You should:

  • stop the agent
  • copy /data/atlassian1/bamboo-agent-home to /home/wasadmin
  • change permissions over /home/wasadmin and whatever directory and file within /home/wasadmin
  • start agent as wasadmin and not as root

Kind regards,

Rafael

Gonchik Tsymzhitov Community Champion Jan 09, 2018

Well, 

you forgot the parameter

-Dbamboo.home

https://confluence.atlassian.com/bamboo/bamboo-remote-agent-installation-guide-289276832.html

 

I see 2 way for fix it. 

  • First one is unix way, like symlink. Just set agent home directory symlink to the correct place. 
ln -s /home/wasadmin /data/atlassian1/bamboo-agent-home

then chown the directory and change in init scripts.

 

  • second one is reinstall remote agent with home parameter.

 

Hope it helps

 

Cheers,

Gonchik Tsymzhitov

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

54 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you