Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Cannot open file from bamboo but works on the server

Hello,

I'm making a build plan that consists so far of a build plan that launches a jmeter test. But i encounter a problem where the command works when i test it directly on the server, but it doesn't work when i test from bamboo. 

It says that it cannot open a certain file, that file is on another server. Once again if i execute the same command int the server's cmd it works...

The command:

 C:/Jmeter/apache-jmeter-3.3/bin/jmeter.bat -J jmeter.save.saveservice.output_format=xml -n -t H:/test/restTest.jmx -l  C:/UserTemp/result.jtl

On Bamboo this command outputs:

 Could not open H:/test/restTest.jmx

 

And if i try directly on the server the test passes with an OK status.

 

I tried stopping bamboo and starting it with "Run As Administrator" but i got the same result could no open.

 

On the other server i've set that file to full control for everyone and same result from bamboo.

 

Am i missing something?

1 answer

1 accepted

0 votes
Answer accepted

Hi Some Guy,

I'm assuming the H: is a mapped network drive. It looks like this drive is not available for the user you're using to start Bamboo or the remote agent.

Have you tried adding a script task right before this task to mount the H: drive during the build execution? It should be something like this:

net use H: \\<SERVER NAME>\<share name>

thanks.

This worked. Thanks!

 

I needed a if exist aswell or the second run will trigger an error.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

251 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you