Can't get visual studios build configuration right

I have a Release|Win32 and a Release|x64 configuration in visual studios every time I try one of them via bamboo I get an error like this:

17-Jan-2012 16:31:07 'x64' is not recognized as an internal or external command,
17-Jan-2012 16:31:07 operable program or batch file.

I have tried wrapping it in single then double quotes or 2 double quotes and it still doesn't work. The options parameter should work like this /rebuild "Release|x64" works outside of bamboo but not within


4 answers

I think you're experiencing a known bug Bamboo (to be precise: in bamboo-dotnet-plugin), see this ticket:

https://jira.atlassian.com/browse/BAM-9922

It's possible you could workaround the problem by using the devenvrunner.bat attached to the BAM-9922, but I don't know where exactly you should inject it into your Bamboo instance - probably you would have to rebuild the bamboo-dotnet-plugin (https://bitbucket.org/atlassian/bamboo-dotnet-plugin).

Ya that looks to be what I am experiencing. Not sure how to rebuild it though. We are just evaluating this product as a potential build system instead of what we have in place now.

Hm... I'm not 100% sure this will work (btw: which Bamboo version are you evaluating?), but I think you could try the following:

Grab the https://maven.atlassian.com/content/groups/m1/com.atlassian.bamboo.plugins.dotnet/jars/atlassian-bamboo-plugin-dotnet-3.4.jar and replace the atlassian-bamboo-plugin-dotnet-x.x.jar you have in your BAMBOO/webapp/WEB-INF/lib directory (remove the old .jar). Then restart Bamboo instance. Depending on which Bamboo version you have and some luck factor this might resolve the problem with '|' (pipe) characters in the goal field. Or might not. :(

0 vote
Joseph Clark Atlassian Team Jan 17, 2012

Hi. Thanks for reporting this. Could you please include the details of your build configuration? What version of Bamboo are you using? Can you include the portion of the build log that shows the full command line that bamboo _tried_ to execute?

0 vote
Colin Goudie Community Champion Jan 17, 2012

You'll need to give us the bamboo build output so we have more context.

In the extra environment variables on the task where you generate the solution files you need to add:

{code}Path=C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\BIN\amd64{/code}

Then you should be able to build with

{code}devenv project.sln /build Release{/code}

and set the platform to amd64.

I'm assuming you're using the Visual Studio builder tool in bamboo?

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,317 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you