Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Build plan branch specific bamboo java specs settings

Hi Bamboo Experts,
We are trying to use Bamboo plan spec to create a build plan that contains branch management with matching Regex, the formula we use is
^(CIPG|CDO)-\d{1,8}$

regex_in_template.png

code snippet:
---------------------------------------------------------------
Plan plan = new Plan(new Project()
.key(new BambooKey("xxxxx"))
.name("xxxxxx")
.description("xxxxxx"),
"xxxxxxxxx",
new BambooKey("xxxxx"))
.planBranchManagement(new PlanBranchManagement()
.createForVcsBranchMatching("^(CIPG|CDO)-\\d{1,8}$")
.delete(new BranchCleanup()
.whenRemovedFromRepositoryAfterDays(0))
.notificationForCommitters());

bambooServer.publish(plan);
-----------------------------------------------------------------
we have existing plans that created manually which contains this regex, so we do an export under 'View plan as Bamboo Specs', check the code into source control and execute it(Publish plan) by building the code. However, the plan that is generated by the java code drops everything after the character comma (,).
regex ends up like
^(CIPG|CDO)-\d{1,


We have tried to escape comma with slash (\) and double slashes (\\), but both ones ends with error.


so what adjustment need to made to original exported plan spec to make it publish correct build plan ?

1 answer

1 accepted

1 vote
Answer accepted

Hello @Herbert Yang,

What's the version of Bamboo you use. 

I tried to reproduce your scenario for Bamboo 6.5. Created plan with given branch settings, exported to Java code, stored it into file. Configured IDE and executed this code from IDE. And plan was created with exactly expected branch settings.

Does it repeats your scenario? If no, please provide your steps to reproduce the issue

Thanks @Alexey Chystoprudov  for the reply.

The version we are using is

'powered by Atlassian Bamboo version 6.2.9 build 60215 - 11 Jan 18'

Could you give it a try with this version&build if possible.

Yes, I can reproduce the problem at Bamboo 6.2.9, 6.3.2 and 6.4.1. But it's fixed in Bamboo 6.5.0

Thanks Alexey!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo Data Center on Kubernetes

Hi, If you are running self-managed environments and looking to adopt modern infrastructure, Bamboo Data Center can now be deployed in a Kubernetes cluster. By leveraging Kubernetes, you can easily...

46 views 0 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you