Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo6.5 installation on EC2 instance- Cannot stop Tomcat

I am installing Atlassian Bamboo 6.5 on an Amazon EC2 instance. I have followed the steps mentioned in this post - http://sdbaddas.blogspot.com/2016/08/how-to-install-bamboo-with-jira.html

These are the version deatils:

Using CATALINA_BASE:   /opt/bamboo
Using CATALINA_HOME:   /opt/bamboo
Using CATALINA_TMPDIR: /opt/bamboo/temp
Using JRE_HOME:        /usr/lib/jvm/java-1.8.0-openjdk-amd64
Using CLASSPATH:       /opt/bamboo/bin/bootstrap.jar:/opt/bamboo/bin/tomcat juli.jar
Server version: Apache Tomcat/8.0.36
Server built:   Jun 9 2016 13:55:50 UTC
Server number:  8.0.36.0
OS Name:        Linux
OS Version:     4.4.0-1052-aws
Architecture:   amd64
JVM Version:    1.8.0_171-8u171-b11-0ubuntu0.16.04.1-b11
JVM Vendor:     Oracle Corporation

When I run start-bamboo.sh, I get this output:

Using CATALINA_BASE:   /opt/bamboo
Using CATALINA_HOME:   /opt/bamboo
Using CATALINA_TMPDIR: /opt/bamboo/temp
Using JRE_HOME:        /usr/lib/jvm/java-1.8.0-openjdk-amd64
Using CLASSPATH:       /opt/bamboo/bin/bootstrap.jar:/opt/bamboo/bin/tomcat-juli.jar
Tomcat started.

But I am not able to browse to the application using the IP address or the servername.

When I run stop-bamboo.sh, I get the following error:

org.apache.catalina.startup.Catalina stopServer
SEVERE: Could not contact localhost:8007. Tomcat may not be running.
org.apache.catalina.startup.Catalina stopServer
SEVERE: Catalina.stop:
java.net.ConnectException: Connection timed out (Connection timed out)
    at java.net.PlainSocketImpl.socketConnect(Native Method)
    at 
java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
    at

java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
    at 
 java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
        at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
        at java.net.Socket.connect(Socket.java:589)
        at java.net.Socket.connect(Socket.java:538)
        at java.net.Socket.<init>(Socket.java:434)
        at java.net.Socket.<init>(Socket.java:211)
        at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:450)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.lang.reflect.Method.invoke(Method.java:498)
        at org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:400)
        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:487)

Has anyone had the same issue? I think it means that Tomcat is not running on the server and it has something to do with the 8007 port which is the SHUTDOWN port mentioned in the server.xml file. Please advise.

1 answer

0 votes
Alexis Robert Community Leader Feb 02, 2019

Hi @Rajashree Baradur

 

you should first check if Bamboo is running after you start it with the following command:

ps -ef | grep bamboo

You should also have a look at the logs in /opt/bamboo/logs/catalina.out to check if you have any errors.

Regarding the shutdown port, don't worry about it: it's normal for this to be different than the application port, the error you're seeing is because there is no Bamboo process running, so Tomcat is unable to perform the shutdown action.

 

There is very probably another problem that prevents Bamboo from starting, this is what you should look for in the first place.

 

Let me know if you have any questions,

 

--Alexis

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

190 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you