Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo won't use the correct JAVA_HOME on Windows

I have bamboo installed on win2012r2. Environment variables are set for java_home and jre_home. Despite that, Bamboo keeps trying to use "C:\Program Files\Java\jdk-16". 

JAVA_HOME = C:\Progra~1\Java\jre1.8.0_311

C:\Users\meh>echo %JAVA_HOME%

JRE_HOME = C:\Progra~1\Java\jre1.8.0_311

C:\Users\meh>echo %Jre_HOME%

Since it keeps looking in that jdk folder I ended up just copying jre1.8.0_311 into a jre folder and got bamboo started, but I'd like to get it running properly. 

Running Atlassian Bamboo version 8.0.4 build 80012 - 27 Oct 21. 


1 answer

How are you setting the JAVA_HOME and JRE_HOME variables? Are you running the `echo` commands as the user that Bamboo runs as? You either need to set the global variables and not set variables for the user Bamboo runs as or only set the variables for the user Bamboo runs as.

Thanks for replying. I have them set under system properties --> environment variables --> system variables. That should be global for all users right? I did not run the echo as the bamboo user. 

It's a little tricky to troubleshoot without knowing how you have things set up.  When we set up any of the Atlassian tools on Windows, we set them to start as a service and create a service account for them to run as an unprivileged user(to be more secure.) Check this doc on how to set up the service.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Bamboo 9.0 is now available

Hey there, Data Center community! I'm Martyna Wojtas and I am the Product Manager for Bamboo Data Center. I’m excited to share that Bamboo 9.0 is now available. We purpose-built this platform to help...

313 views 0 7
Read article

Atlassian Community Events