Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,862
Community Members
 
Community Events
168
Community Groups

Bamboo version has anything to do with builders' version?

Hello guys, 

I'm new at the Atlassian Community and also at the Atlassian's Online world, which seems to be trully full of knowledge... It's just a matter a fact for me to understand how Atlassian's documentation works... I'm just starting. 

I'm studiyng the Realease Notes from the version 6.6 of Bamboo Server in order to check if we can perform a successfull upgrade from the version 5.13 to the 6.6 without having any compatibility issue. 

For this, I'm checking the compatibility between this new Bamboo version and our current Atlassian's softwares, OS, Git, Builders, Plugin's and Oracle versions. 

I found the note bellow, related to the JDK version, and would like to know if it can be applied to the builders' version either. 

So... the Bamboo version has anything to do with the Builders (Maven, Gradle, NPM...) versions installed at the Bamboo Agents?

1 answer

1 accepted

0 votes
Answer accepted

Bamboo tries to be independent from build tools from your environment. There're some limitations we can't ignore (version of Git or supported versions of databases), all requirements to Bamboo Server and Bamboo agent environment are at https://confluence.atlassian.com/bamboo/supported-platforms-289276764.html

Yep, I have already checked the current version as well as support listed right at the same article you have indicated for the following stuff:

  • Application Link (for Confluence, Bitbucket and Jira compatibility) version;
  • OS version;
  • Java version;
  • Database version;
  • Git version.

The only question I have left is exactly the relationship between the builders' version and the Bamboo server...

There are several Maven versions installed for instance, in some of our Bamboo Agents, does it have anything to do with the version of the Bamboo server? 

If I upgrade, will it impact somehow?

I'm not whiling to upgrade/change anything on the Bamboo Agents if it ain't mandatory.

Maven version is not important for Bamboo. The only requirement for agent is JDK 1.8. If you want to use Bamboo Specs stored in repository then Bamboo Server will require Docker

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 9.0 is now available

Hey there, Data Center community! I'm Martyna Wojtas and I am the Product Manager for Bamboo Data Center. I’m excited to share that Bamboo 9.0 is now available. We purpose-built this platform to help...

302 views 0 7
Read article

Atlassian Community Events