Bamboo upgrade - Cannot see "Custom user repository" option in Bamboo 4.1.2

Hello,

We are currently running Bamboo 2.6.1 and I'm trying to do a test upgrade to Bamboo 4.1.2 before upgrading our production server.

Followed the upgrade path 2.6.1 -> 2.6.3 -> 2.7.4 -> 4.1.2 and managed to import the exported zip files into all versions. (A note here: I had to fix the 2.6.1 export's db-export/projects.xml file as the first import to 2.6.3 failed with an integer overflow exception. It's because we have very large artefacts so I had to replace the 10 digits <size>XXXX</size> entries with nine digit values to make the import work).

Anyway apart from this minor problem everything else seems to be working although I will have to run a test upgrade with the whole artefact repository exported from Bamboo as copying the straight 2.6.1 repository layout into 4.1.2 doesn't work.

So my problem is when tried to re-integrate LDAP into the upgraded Bamboo 4.1.2 instance I could not get it working. I have followed the guide at https://confluence.atlassian.com/display/BAMBOO/Integrating+Bamboo+with+LDAP

I have installed the atlassian-user.xml file that I used for 2.6.1 before the initial setup and import of the data into 4.1.2. I did this for the other 2 upgrades 2.6.1 -> 2.6.3 and 2.6.3 -> 2.7.4 and it worked with those upgrades.

After that I could only log in with local admin account. Then I saw in the 4.1.2 guide that I have to enable Custom user repository on the Administration -> User Repositories screen but somehow that option does not show up on my screen! I only have Local users and groups and Users and groups from JIRA or Crowd

Can you please let me know how can I enable the Custom user repository option? Also is there anything I might have done incorrectly to lose this Admin option?

Thank you

2 answers

1 accepted

This widget could not be displayed.


Usually the option "Custom User Repository" will appear in the UI only after the atlassian-user.xml file is well formed and Bamboo is restarted. There are two possibilities I can imagine that can be the root cause. It is either the file is not well formed OR it is not located in the correct directory it should be placed especially that upgrades involves changing the HOME directory. I will suggest that you check the home directory from the system information page and ensure that the file is located in the {{$BAMBOOHOME/xml-data/configuration}} directory.



Regards,
Sultan

This widget could not be displayed.

Many thanks for your help! Missed the information that the atlassian-user.xml file moved from webapp/WEB-INF/classes to $BAMBOOHOME/xml-data/configuration!

Just a tip for future Bamboo releases: Remove the file from webapp/WEB-INF/classes to avoid confusion

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

91 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you