Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo receives 404 when calling BitBucket Cloud users API when creating/updating repository

When creating/updating a linked repository or a plan specific repository that is referencing a BitBucket Cloud repository a 404 is returned when the BitBucket Cloud users or teams API is called.

2020-04-13 12:13:15,778 WARN [http-nio-8085-exec-18] [RESTCall] Response from GET https://api.bitbucket.org/2.0/users/mikerudat/ (404)

2020-04-13 12:13:15,778 ERROR [http-nio-8085-exec-18] [BitbucketApiServiceImpl] 

com.opensymphony.webwork.dispatcher.json.JSONException: JSONObject["uuid"] not found.

at com.opensymphony.webwork.dispatcher.json.JSONObject.get(JSONObject.java:419)

at com.opensymphony.webwork.dispatcher.json.JSONObject.getString(JSONObject.java:590)

at com.atlassian.bamboo.plugins.bitbucket.impl.BitbucketApiServiceImpl.getUuidForUserOrTeam(BitbucketApiServiceImpl.java:319)

at com.atlassian.bamboo.plugins.bitbucket.impl.BitbucketApiServiceImpl.getUuidForAnEmailOrUsername(BitbucketApiServiceImpl.java:218)

at com.atlassian.bamboo.plugins.bitbucket.v2.configurator.BitbucketCloudServerConfigurator.validateUsername(BitbucketCloudServerConfigurator.java:456)

at com.atlassian.bamboo.plugins.bitbucket.v2.configurator.BitbucketCloudServerConfigurator.validateUsernamePasswordCredentials(BitbucketCloudServerConfigurator.java:374)

at com.atlassian.bamboo.plugins.bitbucket.v2.configurator.BitbucketCloudServerConfigurator.validate(BitbucketCloudServerConfigurator.java:271)

at com.atlassian.bamboo.plugins.bitbucket.v2.configurator.BitbucketCloudServerConfigurator.validateForConnectionTesting(BitbucketCloudServerConfigurator.java:292)

at com.atlassian.bamboo.configuration.repository.VcsConfigurationHelperImpl.validateVcsConfigurationForConnectionTesting(VcsConfigurationHelperImpl.java:125)

The username is being passed vs the UUID of the account for the user.  It appears the API call passing the username has been inactivated due to GDPR and the UUID should now be used in Bamboo.

Issuing a curl command against the endpoint does succeed when passing the UUID

curl https://api.bitbucket.org/2.0/users/%7B114aa7e6-a24f-4b58-be59-7620706c07b2%7D

We are using Bamboo 7.0.2

Thank You,

Mike

1 answer

1 accepted

0 votes
Answer accepted

Hi, the same bug is contained in version 6.10.3. Is it fixed in 6.10.5?

No, as we found the bug in the latest version 7.0.2

We are encountering the issue as well in version 6.9.1.

Like Sreekanth Reddy Seelam likes this

Awesome, the workaround was successful.  I added

JVM_SUPPORT_RECOMMENDED_ARGS="-Dbamboo.bitbucket.cloud.use.workspace.api=true"

to bin/setenv.sh for our linux installation.  Thank You!

Like mustafa.ak likes this

does the fix work on version 6.9.1?

I only tested with 7.0.2

Thank you very much Mike..

Worked for me..

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.2 is here!

I'm happy to announce that Bamboo 7.2 has been released and it’s overflowing with awesome new features. This will be the last major Server release before the launch of Bamboo DC. Bamboo logs We...

514 views 5 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you