Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,945
Community Members
 
Community Events
176
Community Groups

Bamboo is not working!

When I am starting bamboo as follows, I got the error message. 

>    cd /opt/atlassian/bamboo/current/bin

>    ./start-bamboo.sh

Warning: To run bamboo in the foreground, start the server with start-bamboo.sh -f 

 

I have started bamboo with tart-bamboo.sh -f  command now bamboo is showing below error. 

Error: Bamboo bootstrap failed: Failed to run pre-bootstrap upgrade tasks. Please contact Atlassian Support at https://support.atlassian.com.

 

To resolve this, I have to add a new license in the bamboo.cfg.xml file. I have a server with centos, but I could not find bamboo.cfg.xml

 

Any solution! 

 

1 answer

0 votes

What does the application log file say the problem is?

You don't put licences into config files, so doing that might actually be the problem - a corrupt config file could stop the startup.

I have checked this doc for the same error. 

Ah, yes, sorry, I was confusing Bamboo with something in another question.

But the principles still apply:

  • Is your config file correctly formatted (with the new licence)?
  • What does the application log say the problem is?

Hello, I have solved the error. 

Thanks, 

I am facing another issue. 

I have configured the SCP task in bamboo to copy the files to a remote server. 

When I push any files from my local system, it reaches the bamboo server successfully, and builds are also created successfully. 

But on the remote server, changes do not reflect.  Any idea?

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
SERVER
TAGS

Atlassian Community Events