Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo express installation hangs on "Please wait while Bamboo sets up your instance"


I'm trying to set up Bamboo on my local computer. My express installation hangs more that 30 minutes on setting up the instance and is not finishing. Tried several times. Checked out the log in BAMBOO-HOME\logs and there I see a bunch of errors, e.g.:

2019-05-20 03:22:37,200 ERROR [http-nio-8085-exec-17] [DefaultDispatcherErrorHandler] Exception occurred during processing request: Unable to instantiate Action, com.atlassian.bamboo.ww2.actions.setup.SelectSetupStepAction, defined for 'selectSetupStep' in namespace '/bootstrap'Error creating bean with name 'reloadableBeanFactories' defined in class path resource [applicationContextPlugin.xml]: BeanPostProcessor before instantiation of bean failed; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.transaction.config.internalTransactionAdvisor': Cannot resolve reference to bean 'org.springframework.transaction.annotation.AnnotationTransactionAttributeSource#0' while setting bean property 'transactionAttributeSource'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'org.springframework.transaction.annotation.AnnotationTransactionAttributeSource#0': BeanPostProcessor before instantiation of bean failed; 
I use jdk-12.0.1 and my JAVA_HOME environment variable is set correctly to the path "C:\Program Files\Java\jdk-12.0.1"

1 answer

1 accepted

1 vote
Answer accepted

The problem occured because I installed Java jdk 12 and it is not supported by Bamboo, so after removing it and installing jdk 1.8 instead the problem was resolved.

Installing jdk 1.8 worked for me too. Thanks!

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events