Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo cannot log in to docker registry when username contains a dollar sign

Gerald Schneider
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
Apr 08, 2020

Harbor uses the $ sign in the username for robot accounts. When using this account in Bamboo to access a private registry the login fails:

08-Apr-2020 15:14:44 at com.atlassian.bamboo.task.TaskExecutorImpl.execute(
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 at$waitAndPerformBuild$0(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.variable.CustomVariableContextImpl.withVariableSubstitutor(
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 at$start$0(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.utils.BambooRunnables$
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 at$
08-Apr-2020 15:14:44 at
08-Apr-2020 15:14:44 Caused by: com.atlassian.bamboo.docker.DockerException: Error running Docker push command. See messages above for details.
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.client.DockerCmd.push(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.service.PushService.execute(
08-Apr-2020 15:14:44 ... 17 more
08-Apr-2020 15:14:44 Caused by: com.atlassian.utils.process.ProcessException: Error executing '/usr/local/bin/docker login -u robot$bamboo --password-stdin', exit code: 125
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.process.DefaultDockerProcessService.execute(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.process.DefaultDockerProcessService.executeSilently(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.process.DockerTaskProcessService.executeSilently(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.client.DockerCmd$AuthorisedCommand.login(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.client.DockerCmd$AuthorisedCommand.execute(
08-Apr-2020 15:14:44 at com.atlassian.bamboo.plugins.docker.client.DockerCmd.push(
08-Apr-2020 15:14:44 ... 18 more

Running the login command from the error message directly on the command line fails as well:

/usr/local/bin/docker login -u robot$bamboo
Error response from daemon: Get unauthorized: authentication required

Surrounding the username with quotes solves this on the command line:

docker login -u 'robot$bamboo'
WARNING! Your password will be stored unencrypted in /home/bamboo/.docker/config.json.
Configure a credential helper to remove this warning. See

Login Succeeded

But I can't use that in the task configuration. I tried to enter the username in the following ways into the textbox:

  • 'robot$bamboo'
  • "robot$bamboo"
  • robot\$bamboo

But it doesn't matter, it's always the same result. When I log in to the registry on the agent host and select Use the agent's native credentials it works as well, but I'd rather not have to manually log in to every agent host individually.

How can I use such a username in a Docker task?

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events