Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo build error. Unable to publish artifact, the source directory does not exist.

I am trying to clean re-install bamboo into the Ubuntu server. However this time my build is failing and these are the logs:

04-Jan-2018 18:39:37 Finished task 'zip the source files' with result: Success
04-Jan-2018 18:39:37 Running post build plugin 'NCover Results Collector'
04-Jan-2018 18:39:37 Running post build plugin 'Artifact Copier'
04-Jan-2018 18:39:37 Publishing an artifact:
04-Jan-2018 18:39:37 Unable to publish artifact []: the source directory /home/bamboo/bamboo-home/xml-data/build-dir/SHOP-REL-BS/builds/ does not exist.
04-Jan-2018 18:39:37 The artifact is required for down stream Stages and Jobs, build will now fail.
04-Jan-2018 18:39:37 The artifact hasn't been successfully published after 683.5 μs

 The log shows that the path for artifact is invalid but I can make sure that the path exist. Pelase see the screenshot:

Screen Shot 2018-01-05 at 09.50.59.png


Any help on this is much appreciated.


3 answers

1 accepted

0 votes
Answer accepted

I have now solved this issue.


The problem was in the artifact defination:

Wrong definition:

Name :

location : builds/

copy pattern :


Correct definition:

Name :

location : builds

copy pattern :

I got the same error 

Unable to publish artifact

Which document told you to use key word `copy pattern`? Did you use Bamboo yaml specs v1 or v2? 


Your sytax looks like v2. But in the official document, the key word is `pattern`

    - name: Binaries
      location: .
      required: true
      shared: true

I had a tab character in the "location" field of the artifact definition ...


Thanks Atlassian for not trimming inputs 

0 votes
edwin Rising Star Jan 05, 2018

Hi Rabi,

Please check and make sure the user running Bamboo has access to the zip file in that directory.

Hi Edwin,

Thank you for your reply.

Please see the permissions for the artifact.

Screen Shot 2018-01-05 at 10.56.29.png

As the user and group is bamboo, wouldn't bamboo have access to the file?

edwin Rising Star Jan 05, 2018

Yes, bamboo should have access. Try adding a task to clean the working directory. 

So the same configuration is working on another server but not after you moved it?

Cleaned the working directory manually before running the plan. Still no luck.


I have done following:

Added a task to see who the user is, shows bamboo as expected.

Added a task to list files, the is there as expected.

Added a task to give permission 777 to

05-Jan-2018 12:24:35 total 285264
05-Jan-2018 12:24:35 -rwxrwxrwx 1 bamboo bamboo 292109077 Jan 5 12:24
05-Jan-2018 12:24:35 bamboo
05-Jan-2018 12:24:35 Unable to publish artifact []: the source directory /home/bamboo/bamboo-home/xml-data/build-dir/SHOP-REL-BS/builds/ does not exist.
05-Jan-2018 12:24:35 The artifact is required for down stream Stages and Jobs, build will now fail.


Previously installed bamboo on the same server with  internal HSQL database but now decided to move to postgresql so re-installed the bamboo.

Used the same exact scripts and settings.

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events