Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo Upgrade SSH issue

I cannot start the old stash 3.1 and bamboo 5.6 on a server due to some security reasons. So I am upgrading them to the latest version on another server. 

BitBucket starts fine without any issues.

But when I start the new bamboo, I got below error in the log file, and these errors wont end, it is like an infinite loop. 

2017-09-13 03:31:08,086 INFO [10-BAM::PlanExec:pool-17-thread-1] [DefaultErrorHandler] Recording an error: Unable to detect changes : TBL-VM : com.atl
assian.bamboo.plugins.git.GitCommandException: command /usr/bin/git ls-remote ssh://f6d781cf-2e5f-4c20-bfba-735f0e700643@127.0.0.1:43470/xxx/xxx-website.git failed with code 128. Working directory was [/opt/bamboo/atlassian-bamboo-6.1.0/temp].,

stderr: Authenticating remote session failed
stdout: Warning: Permanently added '[127.0.0.1]:43470' (RSA) to the list of known hosts.

BAMBOO-SSH-PROXY: [SSH proxy tried to connect to [git@git.xxx.com/xxx.xxx.xxx:7999]: and failed due to the following error: [Authenticating remo
te session failed]: No more authentication methods available]
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

I checked the new BiBucket, Access Keys are not set in all the projects.

But from the ssh error in the log I think it is using a shared credential in Bamboo? Does this error mean that the private key in Bamboo doesnt match with the public key(it is empty in the upgraded bitbucket) in BitBucket? How do I retrieve the private key from the old bamoo file system?

 

 

1 answer

1 accepted

2 votes
Answer accepted

Generally, when you've changed your environment, such as upgrading, migrating physical servers or even URLs, it's best to recreate the application link on both sides (as recommended in  Application Links Troubleshooting Guide) . Try that first as many things are changed in the latest versions of Bamboo and Bitbucket.

If you still cannot get it working, run the same ssh command from a command prompt outside Bamboo and confirm if you are able to successfully authenticate via ssh as the same user and produce result.

Let me explain briefly how we authenticate when Bamboo works with Bitbucket repositories.

  1. When configuring repository definition on Bamboo side (either in Plan or in Administration/Linked repositories) Bamboo will create SSH keypair and will store private key in the repository configuration and upload public key to Stash (it can be seen in the list of SSH keys of a user X who defined repository on Bamboo side).
  2. When running a build Bamboo will present the private key thus making Stash recognise it as user X (no matter how plan was run).

Please, make sure the user saving repository configuration in Bamboo has permissions to the repository in Bitbucket.

it worked after update the application link in bamboo and bitbucket.

Like Jeyanthan I likes this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

195 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you