Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Bamboo SCP Task got stuck in uploading


I am trying to use SCP task in bamboo and it never finishes the upload. This is the log:

28-Aug-2018 15:46:40Starting task 'Copy version file to the server' of type 'com.atlassian.bamboo.plugins.bamboo-scp-plugin:scptask'
28-Aug-2018 15:46:40Connecting to cdx-devint-001 on port: 22
28-Aug-2018 15:46:41Uploading 'C:\builds\15597571-15761411\pasvers.h' to '\c\WebHost\deployments-devint\client'...

I am using shared credentials, and uploading an artifact. I've tried the remote path as:





and got the same result. Any idea about what's happening here?


I did a test, and tried to change the remote path to "pasvers.h", and realized that it created a file name as 'pasvers.h' with single quotes. Maybe that's why is never uploads? It's trying to find the path 'C:\WebHost\deployments-${bamboo.deploy.environment}\client\' with single quotes? How to avoid that?

1 answer

1 vote
Gabriel Ribeiro
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Sep 04, 2018

Hi Renato,

You might be experiencing something similar to the situation described at the below ticket:

Could you please try using Cygwin or MobaSSH as suggested and let us know the results?


Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events