Bamboo - Plan Branch is omitting a task in its builds

We recently added a new task to our builds, and it works fine in the primary plan.  Our branch plan omits it however.  When it builds, it doesn't even show the task at all.  The task is still enabled and runs in the primary.

I've created other jobs and tasks since, everything else seems to be working fine, but somehow the main configuration / task isn't carrying over to the branch.

 

How can I get my branch to run the task?

1 answer

Did the branch plan exist before you added the new task?  I'm not 100% sure, but I'm thinking that the plan does not inherit new changes to the primary plan.

It did exist prior to adding the task. Shortly after I posted though, without any configuration change (and with a couple builds in between) - it randomly added the missing task. I have no idea why it wasn't included in one build, and then was included in the next. Erratic behavior does not make for a very reliable build process

>that the plan does not inherit new changes to the primary plan. They do, but builds started before config change run with the old config.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published yesterday in Jira Ops

Jira Ops Early Access Program Update #2: Let’s talk severity levels

Welcome to your weekly Jira Ops Early access program update, where we’re sharing news and updates on Jira Ops' progress as we work toward our 1.0 release. If you ever want to drop us feedback or idea...

42 views 0 0
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you