Bamboo NUnit System.InvalidOperationException

I'm trying to get Bamboo to Run NUnit tests.  I'm currently getting this error.  I've tried giving the task my sln, my csproj, I even added a step before hand to build the solution, and tried giving the NUnit task the compiled dll, they all resulted in below.  It's pretty much an empty NUnit test project, that has a single test that asserts 1 = 1.
 

And idea on what to try next?

 

Unhandled Exception: System.InvalidOperationException: Showing a modal dialog box or form when the application is not running in UserInteractive mode is not a valid operation. Specify the ServiceNotification or DefaultDesktopOnly style to display a notification from a service application.
error	09-Nov-2014 15:43:15	   at System.Windows.Forms.MessageBox.ShowCore(IWin32Window owner, String text, String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton, MessageBoxOptions options, Boolean showHelp)
error	09-Nov-2014 15:43:15	   at System.Windows.Forms.MessageBox.Show(String text, String caption, MessageBoxButtons buttons, MessageBoxIcon icon)
error	09-Nov-2014 15:43:15	   at NUnit.UiKit.MessageDisplay.Error(String message)
error	09-Nov-2014 15:43:15	   at NUnit.Gui.AppEntry.Main(String[] args)
error	09-Nov-2014 15:43:15	   at NUnit.Gui.Class1.Main(String[] args)
simple	09-Nov-2014 15:43:15	Parsing test results under C:\Atlassian\bamboo-home\xml-data\build-dir\AW-ACC-JOB1...
simple	09-Nov-2014 15:43:15	Failing task since return code of [C:\Program Files (x86)\NUnit 2.6.3\bin\nunit.exe client/C:\Atlassian\bamboo-home\xml-data\build-dir\AW-ACC-JOB1\client\ABlight.Client.Test\ABlight.Client.Test\bin\Debug\ABlight.Client.Test.dll -xml=TestResult.xml] was -532459699 while expected 0
simple	09-Nov-2014 15:43:15	Finished task 'Run Client NUnit Tests' with result: Failed

1 answer

1 accepted

1 vote
Accepted answer

Incase anyone runs against this problem, I had a small error in the file path to the DLL.  However, the big problem is is I was using NUnit.exe instead of NUnit-console.exe  Once I changed that it worked.

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Dec 06, 2018 in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

5,522 views 21 17
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you