It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo NUnit System.InvalidOperationException

Ryan Holzum Nov 09, 2014
I'm trying to get Bamboo to Run NUnit tests.  I'm currently getting this error.  I've tried giving the task my sln, my csproj, I even added a step before hand to build the solution, and tried giving the NUnit task the compiled dll, they all resulted in below.  It's pretty much an empty NUnit test project, that has a single test that asserts 1 = 1.
 

And idea on what to try next?

 

Unhandled Exception: System.InvalidOperationException: Showing a modal dialog box or form when the application is not running in UserInteractive mode is not a valid operation. Specify the ServiceNotification or DefaultDesktopOnly style to display a notification from a service application.
error	09-Nov-2014 15:43:15	   at System.Windows.Forms.MessageBox.ShowCore(IWin32Window owner, String text, String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton, MessageBoxOptions options, Boolean showHelp)
error	09-Nov-2014 15:43:15	   at System.Windows.Forms.MessageBox.Show(String text, String caption, MessageBoxButtons buttons, MessageBoxIcon icon)
error	09-Nov-2014 15:43:15	   at NUnit.UiKit.MessageDisplay.Error(String message)
error	09-Nov-2014 15:43:15	   at NUnit.Gui.AppEntry.Main(String[] args)
error	09-Nov-2014 15:43:15	   at NUnit.Gui.Class1.Main(String[] args)
simple	09-Nov-2014 15:43:15	Parsing test results under C:\Atlassian\bamboo-home\xml-data\build-dir\AW-ACC-JOB1...
simple	09-Nov-2014 15:43:15	Failing task since return code of [C:\Program Files (x86)\NUnit 2.6.3\bin\nunit.exe client/C:\Atlassian\bamboo-home\xml-data\build-dir\AW-ACC-JOB1\client\ABlight.Client.Test\ABlight.Client.Test\bin\Debug\ABlight.Client.Test.dll -xml=TestResult.xml] was -532459699 while expected 0
simple	09-Nov-2014 15:43:15	Finished task 'Run Client NUnit Tests' with result: Failed

1 answer

1 accepted

1 vote
Answer accepted
Ryan Holzum Nov 09, 2014

Incase anyone runs against this problem, I had a small error in the file path to the DLL.  However, the big problem is is I was using NUnit.exe instead of NUnit-console.exe  Once I changed that it worked.

Suggest an answer

Log in or Sign up to answer
This widget could not be displayed.
This widget could not be displayed.
Community showcase
Posted in Statuspage

⭐️Would you recommend Statuspage? Leave a (honest!) review. ⭐️

Hi Community friends, We're working on sourcing more reviews on Capterra – a popular software review site –  to help teams like yours make more informed decisions when choosing an inc...

75 views 3 5
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you