Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo - Express installation with failure

Hello,

I tried to install Bamboo on my local computer for an evaluation. Unfortunately I got the following error message:

2019_10_10_14_44_01_Bamboo_error_reporting_Atlassian_Bamboo.png

I already use jdk 1.8. So this could not be the problem. If any log files are needed please let me know which one.

I appreciate any help to solve this problem!

 

Thanks for your help in advance!

Günther

1 answer

1 accepted

0 votes
Answer accepted

Hi @Günther Bär

If this is a new installation and you have nothing to lose, please try the following:

  1. Stop the process
  2. Delete the Bamboo home directory
  3. Delete the DB created for Bamboo (in case you configured it with an external DB)
  4. Start the process again
  5. Configure your instance

This problem happens when one of the encryption keys (from DB or filesystem) is not available. It could be an issue caused by an interrupted installation, wrong filesystem permissions when restarting the process with a different user or another issue.

Considering that you have nothing to lose I would just try another installation with a clean environment.

Let me know how it goes. =]

Hi @Daniel Santos 

I followed your instructions but unfortunately it didn't work. The same effect as before.

 

The log file says something like

2019-10-14 09:15:38,794 INFO [AtlassianEvent::0-BAM::EVENTS:pool-1-thread-2] [BambooSmackClient] No IM server specified. Bamboo Smack client not initialised.
2019-10-14 09:15:40,167 INFO [http-nio-8085-exec-15] [JohnsonFilter] The application is still starting up, or there are errors. Redirecting request from '/setup/finishsetup.action' to '/error/errorEvents.action'
2019-10-14 09:15:40,198 INFO [http-nio-8085-exec-13] [AccessLogFilter] admin GET http://localhost:8085/error/errorEvents.action?next=%2Fsetup%2Ffinishsetup.action 380029kb

or

2019-10-14 09:15:38,794 ERROR [finishsetupBackgroundThread] [FinishSetupAction] Failed to set up Bamboo
java.lang.RuntimeException: Failed to upgrade
at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:150)
at com.atlassian.bamboo.ww2.actions.setup.FinishSetupAction.execute(FinishSetupAction.java:41)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at ognl.OgnlRuntime.invokeMethod(OgnlRuntime.java:899)
at ognl.OgnlRuntime.callAppropriateMethod(OgnlRuntime.java:1544)
at ognl.ObjectMethodAccessor.callMethod(ObjectMethodAccessor.java:68)
at com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor.callMethodWithDebugInfo(XWorkMethodAccessor.java:98)
at com.opensymphony.xwork2.ognl.accessor.XWorkMethodAccessor.callMethod(XWorkMethodAccessor.java:90)
at ognl.OgnlRuntime.callMethod(OgnlRuntime.java:1620)
at ognl.ASTMethod.getValueBody(ASTMethod.java:91)
at ognl.SimpleNode.evaluateGetValueBody(SimpleNode.java:212)
at ognl.SimpleNode.getValue(SimpleNode.java:258)
at ognl.Ognl.getValue(Ognl.java:470)
at ognl.Ognl.getValue(Ognl.java:434)
at com.opensymphony.xwork2.ognl.OgnlUtil$3.execute(OgnlUtil.java:401)
at com.opensymphony.xwork2.ognl.OgnlUtil.compileAndExecuteMethod(OgnlUtil.java:453)
at com.opensymphony.xwork2.ognl.OgnlUtil.callMethod(OgnlUtil.java:399)
at com.opensymphony.xwork2.DefaultActionInvocation.invokeAction(DefaultActionInvocation.java:438)
at com.opensymphony.xwork2.DefaultActionInvocation.invokeActionOnly(DefaultActionInvocation.java:293)
at org.apache.struts2.interceptor.BackgroundProcess$1.run(BackgroundProcess.java:55)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.IllegalArgumentException: Unable to read cipher data for 0

Hi @Günther Bär

The error you shared means that Bamboo is attempting an upgrade. That would happen only if the home directory is set with a DB configuration.

  • Are you attempting an upgrade or a clean installation?

The steps I shared before should lead you to the Bamboo installation wizard where you would need to configure the instance path, DB connection, admin user etc.

  • Did you get through those after following the steps I shared?

If you didn't, please make sure you are really removing the Bamboo home directory specified by <BAMBOO_INSTALL>/atlassian-bamboo/WEB-INF/classes/bamboo-init.properties.

⚠️ Is you are attempting an upgrade, please make sure you have a backup of your previous instance before removing any data from this server.

Hi @Daniel Santos 

I just tried to make a complete new express installation (no update) and not using an external database. During the installation process I just could enter the credentials for the administration user. Afterwards nothing happens.

I also followed the steps you described later on and removed the whole Bamboo home directory but this didn't work either.

Hi @Günther Bär

Some times we have different errors in sequence and we might think that they are the same thing. The errors you shared are clearly affected by the encryption configuration that is performed when we are upgrading Bamboo or even reinstalling it without cleaning the folders.

Would you mind sharing the errors you see now?
Can you share some more details like:

  • What is the OS used?
  • What is the machine specification? (memory, cpu)
  • What is the Java version installed?
  • Are you using a shared folder to do this configuration? 
    Shared folders could have special permissions defined by the network and this could affect Bamboo installation.
  • Did you see extra progress in the new attempts?
  • What are the errors you see in the last attempts?

Sorry for the number of questions, I want to reduce the back and forth.

Hi @Daniel Santos 

I have the following configuration:

  • OS: Windows 7
  • Memory 16 GB
  • CPU: Intel i7
  • Java: 1.8.0_221
  • No
  • The same

Hope this information will help!

Hi @Günther Bär

I'm led to think you are facing permission issues when Bamboo is trying to create the cipher file in your filesystem. 

Please check this thread:

Are you using a service to run the Bamboo process?
Can you assign a local user with permissions to edit all folders in Bamboo home directory?

In case you are running Bamboo with system user and you want to change it, please check this document:

Hi @Daniel Santos 

Thanks a lot! Now I could finish the installation but afterwards I got the following message in Bamboo:

2019_10_18_10_20_53_Configure_Job_Create_plan_Atlassian_Bamboo.png

I guess there is something to improve in the installation process!

Hi @Günther Bär

I'm very glad that you were able to finish the installation.
I found this issue reported, but it was closed with a fix in our docs:

This was the document changed:



Regarding the embedded DB health check, this DB should only be used for evaluation purposes. Only instances with external DBs should become production ones. That is why the health check fails.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

596 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you