Bamboo Cloud and Elastic Bamboo for Deploying to Azure

Hi All,

I am working on Bamboo Cloud and Elastic Bamboo to deploy the build to Azure Cloud Service. Basically, the requirement is as below

a. Implement the continuous integration using Bamboo Cloud

b. Get the source code from Bitbucket Cloud

c. Use Amazon EC2 instances as remote agents (Elastic Bamboo)

d. Build the project on remote instance (Amazon Ec2 Instance) 

e. On successful build, prepare the package that can be uploaded to Microsoft Azure Cloud Service

f. Once the package is ready, upload the package to Azure Cloud Service

g. Once the deployment is completed, trigger the Testing Automation Scripts

I have achieved the above using Bamboo Server, but want to try with Bamboo Cloud and Amazon EC2. 

I have been successful in creating the Amazon EC2 instance and get the source code checked out in it though the Bamboo Job / Task. But while building the project, I am getting the below error

 

Project "C:\build\AC-AC-JOB1\CIPOC.sln" (1) is building "C:\build\AC-AC-JOB1\CIPOC\CIPOC.csproj" (2) on node 1 (default targets).
C:\build\AC-AC-JOB1\CIPOC\CIPOC.csproj(327,3): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\WebApplications\Microsoft.WebApplication.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.
Project "C:\build\AC-AC-JOB1\CIPOC.sln" (1) is building "C:\build\AC-AC-JOB1\CIPOC.Azure\CIPOC.Azure.ccproj" (3) on node 1 (default targets).
C:\build\AC-AC-JOB1\CIPOC.Azure\CIPOC.Azure.ccproj(61,3): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Windows Azure Tools\2.7\Microsoft.WindowsAzure.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.
"C:\build\AC-AC-JOB1\CIPOC\CIPOC.csproj" (default target) (2) ->
C:\build\AC-AC-JOB1\CIPOC\CIPOC.csproj(327,3): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\WebApplications\Microsoft.WebApplication.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.
"C:\build\AC-AC-JOB1\CIPOC.Azure\CIPOC.Azure.ccproj" (default target) (3) ->
C:\build\AC-AC-JOB1\CIPOC.Azure\CIPOC.Azure.ccproj(61,3): error MSB4019: The imported project "C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v11.0\Windows Azure Tools\2.7\Microsoft.WindowsAzure.targets" was not found. Confirm that the path in the <Import> declaration is correct, and that the file exists on disk.

 

Probably once the complete solution is ready, I can share the information with everyone. But need help during the initial phase.

Thanks 

 

1 answer

This widget could not be displayed.

Did anyone figure out how to fix this? I also have the same issue buildin a .net MVC application.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

297 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you