Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,466,638
Community Members
 
Community Events
176
Community Groups

Bamboo CLI addTask does not work for fields that have values with colons

Hi,

I've been having trouble using the bamboo cli to create a AWS S3 Object task. The bamboo cli uses a comma separated list where the fields are mapped to their values via colons

--fields field1:value1,field2:value2

However, this fails when the value contains colons, such as in the artifactToUpload field for the AWS S3 Object task:

-1:1:1:DEPLOYNAME: all artifacts

I noticed in the bamboo logs that the request ends up only using the value up until the first colon, so using the example above, only -1 is used in the request and fails.

However, when I switched to using the --field1 --value1 syntax, the call worked fine and created the task in bamboo. But since I had to go up to field7 using this syntax and since parameters field3 and above are deprecated, I was wondering if there was a workaround to getting this to work using the --fields parameter.

 

 

2 answers

Use multiple field parameters to specify one field at a time - it is a bit easier.

In general, if you have CLI parameters that are comma and/or colon separated and the value contains a separator character, you need to single quote the value in order to prevent the embedded separator from being mis-interpreted.

0 votes

Hi! 

 

As I understand you wrote about bamboo cli from Bob-Swift toolset. 

Therefore I suggest you raise by link 

https://bobswift.atlassian.net/servicedesk

 

 

Cheers,

Gonchik Tsymzhitov

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events