Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

Recognition

  • Give kudos
  • My kudos

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Atlas-run -- AnnotationAwareAspectJAutoProxyCreator is only available on Java 1.5 and higher Edited

We are currently in the process of upgrading to the latest Bamboo version,  however for the time being we are on 5.6.

Until the upgrade is complete, I need functionality to Trigger Deployment from Tasks.

I've created a Plugin as per official documenation -- which default to the latest Bamboo version. 

Due to backwards compatiablity issues around the Deployment Execution Service, I've update the plugin for 5.6 support. 

See code @:

https://github.com/vicsz/Bamboo-Deployment-Trigger-Task-Plugin

However, once I've down graded to 5.6 .. I've been unable to succesfully run atlas-run. 

I'm running into the following errors:

Caused by: java.lang.IllegalStateException: AnnotationAwareAspectJAutoProxyCreator is only available on Java 1.5 and higher

SEVERE: Exception sending context initialized event to listener instance of class com.atlassian.bamboo.ww2.actions.setup.BambooContextLoaderListener

FATAL [localhost-startStop-1] [UpgradeLauncher] Failed to initialise Bamboo container

[INFO] [talledLocalContainer] java.lang.NullPointerException

 

Either I missed something in my configuration ?? or the previous run of atlas-run at a newer version is some how polluting the current invocation. 

Note, that I am using a current JDK (1.8), and I've tried mvn-cleaning including completly wipping the /target dir. 

1 answer

1 accepted

1 vote
Answer accepted

I think you need to use older Java (7?), it looks like your Java 8 is not recognised.

Thought so too .. but I've explicitly specified complication to 1.6 in the maven-compiler-plugin settings. Which I would assume would do the trick, not so. 

It won't because it does not affect the reported JVM version.

You seem to be correct ...  it's rare that I see software not working on newer versions of the JVM.  

Though the issue that I'm running into now is that the latest version of Atlas-SDK is compiled with 1.8,  and I can't seem to find older versions with brew on OSX. 

Lots of Yak Shaving .. sigh

 

 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

675 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you