Agent fails to load after failure on startup due to unsupported java version

AMI: ami-17f7a772

Agent loads then produces this error:

Running startup scripts...
Exception in thread "main" java.lang.UnsupportedClassVersionError: com/atlassian/bamboo/agent/elastic/startup/RunStartupScripts : Unsupported major.minor version 52.0
	at java.lang.ClassLoader.defineClass1(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
	at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
	at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
	at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
	at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
Starting Elastic Bamboo Agent...

Following this, no custom startup scripts run.

UPDATE:

This appears to only effect instances that have custom startup scripts.

We were able to work around this by manually running the scripts on the instances.

**This is not an acceptable long term work around as it forces us to not be able to use spot instances reliably as it considerably drives up our working costs*****

 

UPDATE 2: 

Received new temporary AMI as a workaround from Atlassian support. Appears to have added java 8.

 

9 answers

1 vote

The problem should be fixed now.

What do you mean 'fixed'. Do we have to use an updated AMI?

image configurations get updated with the new AMI automatically for this supplied Ubuntu image. Being automatic introduced the problem in the first place, in our case

What is the updated AMI? I tried the ami-55f5a530 and I still getting the exactly same problem

I was able to switch back to the Stock S3 image and it is working. that image does not have the jdk-8 capability but it has java 8 on it.

I'm seeing that same error, in our instances also

We began seeing it starting this morning. We have made no changes to configuration on our side. Is this reflective of your experience as well?

Seems sudo uses java7 and the bamboo agent needs java 8

We are seeing the same also. Just started this morning (11/2).

We are having the same issue as everyone else. No changes were made by us. It was working yesterday.

I was able to place a ticket with Atlassian Support and they supplied me a work around AMI that has corrected the issue.

Not encouraging when the makers of our Continuous Deployment tool make this sort of mistake with a deployment.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,814 views 0 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you