Problem enabling Greenhopper 6.0.4 on JIRA 5.1.6

Hi,

I'm having troubles on enabling Greenhopper 6.0.4 on JIRA 5.1.6 WAR Linux Ubuntu 12.04 LTS. I have the following message :

The JIRA server could not be contacted. This may be a temporary glitch or the server may be down.

In jira logs :

2012-10-07 17:50:36,033 http-bio-8080-exec-3 INFO root 1069x259x1 16c5ec1 82.241.191.95 /rest/plugins/1.0/com.pyxis.greenhopper.jira-key atlassian.plugin.util.WaitUntil Plugins that have yet to be enabled: com.pyxis.greenhopper.jira , 0 seconds remaining

2012-10-07 17:50:37,034 http-bio-8080-exec-3 INFO root 1069x259x1 16c5ec1 82.241.191.95 /rest/plugins/1.0/com.pyxis.greenhopper.jira-key atlassian.plugin.manager.DefaultPluginManager Disabling com.pyxis.greenhopper.jira

2012-10-07 17:50:37,037 http-bio-8080-exec-3 ERROR root 1069x259x1 16c5ec1 82.241.191.95 /rest/plugins/1.0/com.pyxis.greenhopper.jira-key plugin.osgi.factory.OsgiPlugin Never resolved service '&ao' for plugin 'com.pyxis.greenhopper.jira' with filter (objectClass=com.atlassian.activeobjects.external.ActiveObjects)

I have tried to :

- Delete folders work, .osgi-plugins, .bundled-plugins, re-indexation

- Downgrading to 6.0.3, 6.0.2, 6.0.1

- Shutdown and restart many times

I'm short on ideas now. Can I ask you for your assistance ?

Thanks in advance for your support,

Huy NGUYEN NHU

3 answers

1 accepted

Accepted Answer
0 votes

Finally, I downloaded to JRE 1.6 and Tomcat 6 and it works better !

I had the same problem and it was the result of manually installing a newer version of ActiveObjects. I had downloaded activeobjects-jira-spi-0.21.1.jar and activeobjects-plugin-0.21.1.jar and uploaded them through the UPM. After that, GreenHopper would not enable.

I was not able to uninstall these from the UPM so I manually deleted them from the filesystem; no errors, it just didn't remove them. They are located in {JIRA-home}/plugins/.osgi-plugins/transformed-plugins and {JIRA-home}/plugins/installed-plugins so if you remove them from there it is uninstalled. I still had the 19.7 version of these two plugins.

Finally, I downloaded to JRE 1.6 and Tomcat 6 and it works better !

rwfwedwfdxassqfrwwfwdw

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Agile

What's new this quarter in Confluence Server - August 2018

Hello Atlassian Community! My name is Ada , and I'm the Product Marketing Manager for Confluence Server at Atlassian. If you missed   our last post, we're transitioning to quarterly updates&nb...

156 views 0 1
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you