Formatting DateTime doesn't seem to work on JETI Cloud

Hello,

I'm trying to show a simple Date of a DateTime custom field value. in JETI email template on JIRA Cloud.

Here is my code in the email template:

#set($formatter = $!jetiFieldFormatter.getJiraDateTimeFormatter("dd-MM-yyyy")) 

Date1: $!jetiFieldFormatter.formatSafely($formatter,$!issue.getCustomFieldValueAsObject("customfield_10115"))

Date2: $!jetiFieldFormatter.formatSafely($formatter,$!jetiFieldRenderer.renderCustomFieldAsObject($issue, 'customfield_10115'))

 

Both of the Dates are empty (nothing is shown), although #renderCustomField($!issue, 'customfield_10115') returns the right value (in the full format).

Am I missing something or doing something wrong or is this a bug?

0 answers

Suggest an answer

Log in or Join to answer
Community showcase
Bridget Sauer
Published Feb 08, 2018 in Agile

Community Showcase: Getting to know Kemal, AUG Leader from Bosnia and Herzegovina

  Cheers to Kemal Bajramovic, our first ever AUG Leader to be Showcased. AUG Leaders are passionate experts who find time in their own busy lives to host Atlassian themed events to share ...

196 views 3 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot