Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,359,907
Community Members
 
Community Events
168
Community Groups

base url /secure/PortfolioPlanCreate.jspa?ref=1 keep giving error after installion

Edited

I think the plugin is not installed correctly or something to do with the database, tried reinstalling the portfolio plugin it still keeps showing this error, what can I do.

Caused by: com.atlassian.rm.common.bridges.jpo1.api.Portfolio1Exception: com.radiantminds.roadmap.api.Portfolio1Exception: java.lang.RuntimeException: Entity Manager not accessible via AODoorStop.
	at com.atlassian.rm.common.bridges.jpo1.impl00.common.ExceptionHandler.handleException(ExceptionHandler.java:18) [?:?]
	at com.atlassian.rm.common.bridges.jpo1.impl00.permissions.PluginPermissionsServiceBridge00.check(PluginPermissionsServiceBridge00.java:62) [?:?]
	at com.atlassian.rm.common.env.permissions.JiraPluginPermissionsService.check(JiraPluginPermissionsService.java:33) [?:?]
	... 262 more
Caused by: com.radiantminds.roadmap.api.Portfolio1Exception: java.lang.RuntimeException: Entity Manager not accessible via AODoorStop.
	at com.radiantminds.roadmap.common.api.DefaultApiPortfolioPermissionsService.check(DefaultApiPortfolioPermissionsService.java:31) [?:?]
	at com.atlassian.rm.common.bridges.jpo1.impl00.permissions.PluginPermissionsServiceBridge00$1.perform(PluginPermissionsServiceBridge00.java:52) [?:?]
	at com.atlassian.rm.common.bridges.jpo1.impl00.permissions.PluginPermissionsServiceBridge00$1.perform(PluginPermissionsServiceBridge00.java:38) [?:?]
	at com.atlassian.rm.common.bridges.api.plugins.access.DefaultBundleServiceAccessor.perform(DefaultBundleServiceAccessor.java:39) [?:?]
	at com.atlassian.rm.common.bridges.jpo1.impl00.permissions.PluginPermissionsServiceBridge00.check(PluginPermissionsServiceBridge00.java:38) [?:?]
	... 263 more
Caused by: java.lang.RuntimeException: Entity Manager not accessible via AODoorStop.
	at com.radiantminds.roadmap.common.data.activeobjects.ActiveObjectsAccessorImpl.getEntityManager(ActiveObjectsAccessorImpl.java:123) [?:?]
	at com.radiantminds.roadmap.common.data.activeobjects.ActiveObjectsUtilitiesImpl.getOrCreateConnection(ActiveObjectsUtilitiesImpl.java:325) [?:?]
	at com.radiantminds.roadmap.common.data.persistence.ao.sql.BaseAOPersistenceSQL.sql(BaseAOPersistenceSQL.java:261) [?:?]
	at com.radiantminds.roadmap.common.data.persistence.ao.entities.permissions.sql.PermissionSQL.testPluginPermissions(PermissionSQL.java:32) [?:?]
	at com.radiantminds.roadmap.common.data.persistence.ao.entities.permissions.PortfolioActiveObjectsPermissionPersistence.testPluginPermissions(PortfolioActiveObjectsPermissionPersistence.java:79) [?:?]
	at com.radiantminds.roadmap.common.permissions.PluginPermissions.checkPermission(PluginPermissions.java:66) [?:?]
	at com.radiantminds.roadmap.common.permissions.PluginPermissions.check(PluginPermissions.java:53) [?:?]
	at com.radiantminds.roadmap.common.api.DefaultApiPortfolioPermissionsService.check(DefaultApiPortfolioPermissionsService.java:27) [?:?]
	... 267 more
Caused by: com.atlassian.activeobjects.internal.ActiveObjectsSqlException: There was a SQL exception thrown by the Active Objects library:
    Database:
    	- name:MySQL
    	- version:5.7.27
    	- minor version:7
    	- major version:5
    Driver:
    	- name:MySQL Connector Java
    	- version:mysql-connector-java-5.1.48 ( Revision: 29734982609c32d3ab7e5cac2e6acee69ff6b4aa )
    
    com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry '0' for key 'PRIMARY'
	at com.atlassian.activeobjects.internal.EntityManagedActiveObjects.create(EntityManagedActiveObjects.java:94) [?:?]
	at com.atlassian.activeobjects.osgi.TenantAwareActiveObjects.create(TenantAwareActiveObjects.java:266) [?:?]
	at sun.reflect.GeneratedMethodAccessor1414.invoke(Unknown Source) [?:?]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [?:1.8.0_202]
	at java.lang.reflect.Method.invoke(Method.java:498) [?:1.8.0_202]

3 answers

1 accepted

0 votes
Answer accepted
Andy Heinzer Atlassian Team Sep 20, 2019

Hi @joshuand1990 

Welcome to the Atlassian Community.  Sorry to hear that you are seeing this error with trying to use Portfolio.  Thanks for posting the exception here.  It does help us to better understand the cause of the problem here.

The specific error being thrown in the stack trace of interest here is:

com.mysql.jdbc.exceptions.jdbc4.MySQLIntegrityConstraintViolationException: Duplicate entry '0' for key 'PRIMARY'

This error is common enough that we have created a KB to help here. Please see Duplicate entry 0 for key PRIMARY exceptions in log for details.  This error is getting thrown because the MySQL database that Jira is trying to use has an extra parameter in it's configuration that should not be there.  This sql_mode = NO_AUTO_VALUE_ON_ZERO setting is also mentioned in the guide Connecting Jira applications to MySQL 5.7.  There are though steps you can follow to correct this problem.  From the KB:

Resolution

  1. Stop the application.
  2. Stop MySQL
  3. Edit the my.cnf file (often named my.ini on Windows operating systems or my.cnf on UNIX operating systems) in your MySQL server.
  4. Remove NO_AUTO_VALUE_ON_ZERO from sql_mode.

  5. Start MySQL
  6. Start the application.

I hope this helps, please let me know if you run into any problems with this.

Cheers,

Andy

Hi @Andy Heinzer 

Your help was much appreciated, the resolution was perfect.

Andy Heinzer Atlassian Team Sep 23, 2019

Yay!  Glad to hear that this helped fix the problem.   Just so you know, you can click the Accept Answer button next to my answer here.  This will marked the issue as solved, and in turn can help other users that might search for similar terms in the future to find this answer a bit easier.

Cheers,

Andy

Hi Andy, Your help is much appreciated, the resolution was perfect.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Jira

Online AMA this week: Your project management questions answered by Jira Design Lead James Rotanson

We know that great teams require amazing project management chops. It's no surprise that great teams who use Jira have strong project managers, effective workflows, and secrets that bring planning ...

179 views 1 6
Read article

Atlassian Community Events