It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

What permissions required for setting a Parent on an Epic?

We are experiencing an issue where some of our users are unable to find and set a Parent for an Epic. We have setup Portfolio as seen in this screenshot:

Screen Shot 2019-11-04 at 10.48.45 AM.png

 

We then setup our Epics to display the Parent Link field (since it is our understanding that Jira/Portfolio require you to set the Parent instead of setting the child). When I open an Epic and search for a "Feature" in the Parent Link field I see everything working as expected and can make the link successfully. However, when some other users attempt the same thing I am doing they are unable to find the "Feature" and see the following:

image (7).png

 

I assume this is a permission issue but I am unsure which permissions need to be altered. I know we had a similar problem a year ago but the guy that figured it out is no longer with our company, that is why I currently have permissions to set the Parent Link. 

One of the people experiencing the problem is our Portfolio admin and I went into Jira and made him an Admin of the Project in question, but that didn't solve the issue. So, short of just going around trying to give him access to everything, I am not sure where to specifically look.

Can anybody help me out with this issue?

3 answers

1 accepted

0 votes
Answer accepted

Alright we figured out what was going on. Using the following page:
https://confluence.atlassian.com/jiraportfolioserver/permissions-967895173.html

 

We had assumed that the Portfolio for Jira administrator permission was enough to allow somebody to set a Parent link for an Epic, turns out that we need to add people to the Portfolio for Jira user permission as well. It wasn't really clear to us by just reading the documentation but it helped us try a few things until we figured it out. After granting our Portfolio Administrator the Portfolio for Jira user permissions it resolved the issue, as an extra validation step we also granted the Portfolio for Jira user to a developer with no other Portfolio access and it allowed him to set a Parent link for Epics as well.

Thanks Dave,

I just discovered the same thing. I removed jira-software-users form the Portfolio User permissions and linking started to fail.

My problem is that now any user can can create a plan and given the power of plans I am not comfortable with this. Did you bump into the same issue? Did you resolve?

Regards,
Warren

Warren,

I believe we just added individual users to the Portfolio for Jira user permission and we only did that for Product Owners and Dev Team Leads.

Hi @Dave Armstrong

 

Have you tried checking if there is any security level restriction on your the feature which the user is trying to add in the parent link field.

Also check if the user is able to access the feature directly from JIRA and view the issue.

Let us know if you are using portfolio in cloud or in server.

 

Regards,

Vijay Ramamurthy

I was just looking into project permissions but that didn't appear to do the trick. I then started looking into the Parent Link field but I don't see any ability to set/control permissions on the individual field. Also looked at the permissions for Portfolio but I didn't see anything out of the ordinary there.

The user was the one that actually created the Feature and had full access to it (outside of linking an Epic to it).

I believe we are using Portfolio in the Cloud.

0 votes
Kathy Hart Community Leader Nov 05, 2019

Question: Do you create your Features in the same Project with your Epics? Or do you follow the method of putting your Features and Initiatives in a separate Project by themselves? 

If you use the second option, it could be that they do not have permission to see the Project where your Features / Initiatives are stored. 

We have tried it both ways, in the example I provided the Feature and Epic are within the same project and I gave our 'Portfolio Admin' Administrator permissions to the project in question but that didn't help. I actually tried that before I posted here.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Advanced Roadmaps

3 short videos to help you get started with Advanced Roadmaps

Hi community, I’m Roi, a product manager working on Advanced Roadmaps for Jira. While Advanced Roadmaps is a powerful tool to plan and track work at scale, we know it can be challenging to get star...

3,714 views 23 15
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you