Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Adding issues to epic doesn't show on portfolio

I have two boards feeding into my portfolio plan. When I go into an issue in JIRA and set the EPIC, the change doesn't seem to be propagated to my portfolio plan.

I know there are several others with this issue, none of the fixes do not work for me or are not possible on my version of Portfolio (why are there so many versions?).

I find this bug or limitation very irritating and could mean the difference between my company paying for this or not. We are currently trialling portfolio.

NOTE: Re-importing issues through the configuration menu does not work to fix this problem


A gif of my problem here: http://gph.is/2ovkKUe

How can this be fixed? Is there a bug or is there something I am not doing correctly.

17 answers

I am having almost the opposite issue.  I have issues that have been created, and I have epics that have been created.  But in portfolio I can't see the Epic to link to.  I even have some issues that already have an epic linked to it but that doesn't show up in portfolio as linked.

Hi, 

having a fix version that isn't included in the plan will cause this.  Remember that on the versions screen, all versions are un-selected by default, so you need to select them, but if the Issue has a fix version that isn't part of the plan, then the data will not be imported into the plan.

 

Hope this helps someone.

All my issues have Fix Version selected, and the status is not ‘Done’, and I am using the Board as a Source, which shows all my epics. It’s frustrating that all epics and Initiatives were reflected in Portfolio for some time, but they disappeared yesterday.  Some Initiatives  are missing in the drop down, so I can’t even select them manually. The issue of disappearing epics and Initiatives in Portfolio the users have been experiencing for at least couple of years? It seems like this big cannot be fixed.

CAN SOMEBODY FROM ATLASSIAN TEAM CLARIFY PLESSE ??????? 

Like Terri Worth likes this

This works for me. But i still think it's a bug. If you create a story under an epic, epic under an inititative - it will show up right away even without a proper fix version.

Some other people they that explicit re-indexing helped. 

0 votes

Hey Colin, thanks for bringing this to our attention - the behaviour you've described is certainly not expected.

The first thing that comes to mind is that the issue sources in your plan somehow don't pull in those issues, either due to board filter or explicit exclusion of the stories' release.

Could you please create a support ticket so our devs can investigate and track your issue? https://support.atlassian.com/

Kind regards,
Rhys

Hi Rhys,


Thanks for the response. The jiras actually *did* appear under the epic. However, it did take a while and the action of them appearing or how I made them appear isn't deterministic.

So I think there's still an issue here, as it took some time for the jiras underneath to appear.

Hi,

I had an identical issue after creating a new epic from Portfolios side and after committing it moving an existing story into it.

The epic was showing but the issue underneath it wasn't even though it was visible from Jira. Also visible on backlog and the filter.

I tried also Configure->Issue Sources->Configure Sources without any affect.

Finally when I went to one of the stories and changed it's remaining estimate to zero those both appeared on Portfolio also. 

Don't know if the change on the remaining estimate was the answer but there's definitely still an issue here.

Best Regards,

Markus

Some issue here, Created an epic in Portofolio and pushed to a jira software project then added some things in jira software to the epic and no changes are showing up in portfolio. I've gotta say using atlassian products is an excercise in frustration, I'm constantly running across bugs like this that just kill my productivity. I have no idea when this will be fixed but looks like from the date of the original report its been around awhile.

Same for me. Created an epic in Portfolio and assigned tasks in jira to it. The epic does show up, the tasks do not. What do I have to do to fix this?

In my case the tasks were not showing because the workflow category of the tasks was "done", once I changed it to "in progress" or "to do" I could see all the tasks assigned to the epics.

I have the same issue.

I have these same kind of issues right now. Portfolio seems like exactly the product we need in combination with JIRA but this is really awful. 

 

Atlassian: JIRA is kick ass and Portfolio looks really nice but could you please fix these god damn bugs? 

Same here, I have issues that have an specific epic link, these issues are displayed on my scrum boards (used as sources in my portfolio plan) correctly, I see the epic link on the the issues that are part of an specific epic. Yet, on my plan some epics do not show all issues that contain their specific epic link.

 

What to do? 

 

Is this a bug?

 

Is there any documentation you can refer me to?

 

I can see that you are not giving answers to this issue, what is going on?

1 year and the bug is still open, classic Atlassian

believe I'm running into same issue...trying to create a new plan (added project and board) with underlying epics and they don't appear in the "Confirm what is in scope".

 

Is there timeline for this issue?

Hi, I have the same issue, is there any bug created for this? Is there a workaround?

Same issue here. My company is trialing Portfolio. Why is Atlassian quiet about this issue?  Where is the fix? 

I have the exact same issues. A good number of epics is missing in Portfolio. Another issue is that Epic is listed in Portfolio but there is no ability to expand it to view the stories linked to it. Also, one of my Initiatives is missing with all associated epics. I am using the project Board as a source, which reflects all my epics and stories correctly. My company recently purchased Portfolio license for a year. If the issue of stories/epics/initiatives disapering in Portfolio is not fixed, the product is useless. If so, we would like to requeast a refund. Could anyone from Attlassian clarify please?    

Like # people like this

I created a brand new Plan in Portfolio and chose the project Board as a source. It now shows all my Initiatives and Epics. The Stories that have status 'Done' are not shown under the associated Epic though (it would be nice to see them). I am assuming it also applies to Initiatives and Epics with 'Done' status (none of my Initiatives and Epics have 'Done' status). Although I don't undertand why some Inititives/Epics are missing in my previously created Plans in Portfolio, I feel better now when I can see all in my newly cretaed Plan. So try to create a new Plan. Again, you won't see the Stories that have 'Done' status at the time of creation of the Plan.    

Like Thomas Duckett likes this

I also have the same issue!!!!

I've got the same thing going on; the EPIC and associated Task are not showing in Portfolio.  There are no fix versions input, both are In Progress.  No matter how many times I hit "calculate" it won't pull it into Portfolio from JIRA.

0 votes
BillyP Community Leader Apr 30, 2019

I saw this same error.  :(

So then I tried a re-index.  

Cog -> System -> Re-indexing. 

 

I did a background re-index and BOOM, all my stuff is in Portfolio now.  

If you don't have the Cog, speak with your system admin.  :)

BillyP Community Leader Apr 30, 2019

Also, another thing you can check, is that the Team is updated on the Issue.  Lots of Portfolio stuff is organized around the Teams, so don't forget to double check that one :)

Hey guys i had a similar issue and i have solved it (well i did on my side). this is what i did:

 

Jira:

1) Make sure that you have an epic created

2) Make sure that your Issuetypes are linked to the EPIC (Epic Link)

3) Make sure that your Query / Filter that will be used by Portfolio includes the Issue types you want to include in your plan

4) make sure that you have a sub task created under the issuetype (preferably estimated)

Portfolio:

1) Make sure that when you create your plan, you use the "Filter" option as your source, the same one that you created above.

2) Make sure the Issuetypes are selected in "Scope" section BEFORE you finish the plan initiation (it seems to default to not selected)

3) once created, Make sure that all your filters on your plan are MAX'd out i.e "All" /  "Full" etc.

Also, This may help: https://confluence.atlassian.com/jiraportfoliocloud/creating-your-first-plan-and-succeeding-828785200.html?_ga=2.247841092.2126531479.1563958505-949520747.1561106176

You should now see this... Hope it helps. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Advanced Roadmaps

3 short videos to help you get started with Advanced Roadmaps

Hi community, I’m Roi, a product manager working on Advanced Roadmaps for Jira. While Advanced Roadmaps is a powerful tool to plan and track work at scale, we know it can be challenging to get star...

6,620 views 25 19
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you