Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,364,092
Community Members
 
Community Events
168
Community Groups

Unable to resolve class in Scriptrunner import clause

Hi.

I'm writing a Scriptrunner script to manage Bamboo build plans upon Jira issue status change. For that I need to get an assigned to the issue branch. I do it that way:

import com.atlassian.jira.plugin.devstatus.impl.DefaultDevStatusSummaryService

def ccm = ComponentAccessor.getComponentClassManager()
def service = ccm.newInstance("com.atlassian.jira.plugin.devstatus.impl.DefaultDevStatusSummaryService")
def currentUser = ComponentAccessor.getJiraAuthenticationContext().getLoggedInUser()

//def issue = ComponentAccessor.getIssueManager().getIssueObject("CDI-5")
def details = service.getDetailData(issue.id, "stash", "pullrequest", currentUser).right().get().getDetail()

When I have first line with "import" commented out it works fine but syntax checker in the script editor underlines last line with "service.getDetailData" with error that "getDetailData" is unknown for "java.lang.Object", which is understandable. But if I uncomment first line I get a compiler error "unable to resolve class com.atlassian.jira.plugin.devstatus.impl.DevStatusSummaryService". Why is that? 

If I comment out first line and check type of the "service" variable I get:

class com.atlassian.jira.plugin.devstatus.impl.DefaultDevStatusSummaryService

 

1 answer

0 votes

this is not allowed .

How do you trigger the execution?

Add the directory to your script roots-https://scriptrunner.adaptavist.com/latest/jira/#_script_roots

Try the import with "@WithPlugin" directive e.g

@PluginModule
AllPublicStructureComponents structureComponents

// Specify that classes from this plugin should be available to this script
@WithPlugin("com.atlassian.jira.plugin.devstatus.impl.DefaultDevStatusSummaryService")

What is not allowed? Using plugins in script?

So far I don't trigger the execution but start the script manually. In the future I'm going to run it as a post-function in workflow status transition.

Try the import with "@WithPlugin" directive e.g

 I tried. The result was a bit different but the error was same:

unable to resolve class com.atlassian.jira.plugin.devstatus.impl.DevStatusSummaryService @ line 4, column 1. @WithPlugin("com.atlassian.jira.plugin.devstatus.impl.DefaultDevStatusSummaryService")

@WithPlugin("enter plugin.key here")

Find the key here: Manage addons>select plugin>addon key.

This annotations only work when running a script that is under a script root (the script directory is teh script root by default. place your script there)…​ not a script outside a script root, nor code pasted into the console.

What is not allowed?

Your approach to import another plugin in your script.

Yeah, you're right about @WithPlugin annotation.

Still if I comment "import" clause out I can run the script from script console (it accesses branches and pull requests of the issue). So it seems it's possible to access plugins from console scripts. How can it be?

+1 for

How can it be?

You should create a support request to report unexpected behaviour. They should be able to explain it away. I am also curious.

Ok, thanks. 

Created a request to Adaptavist https://productsupport.adaptavist.com/servicedesk/customer/portal/2/SRJSUP-4549

Let's see what they say

Actually even when running from file it gives same error:

2018-04-25 16:04:09,172 WARN [common.UserScriptEndpoint]: Script console script failed: org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: file:/var/atlassian/application-data/jira/scripts/test.groovy: 4: unable to resolve class com.atlassian.jira.plugin.devstatus.impl.DefaultDevStatusSummaryService @ line 4, column 1. @WithPlugin("com.atlassian.jira.plugins.jira-development-integration-plugin") ^ 1 error

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events