Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,374
Community Members
 
Community Events
165
Community Groups

Sorting and searching of scripted number field does not work

Hi there,

 

I have a scripted number field which gives me the number of requirement tests for a story. The script only executes a JQL (type = Testfall AND issue in requirementTests(" + issue.key + ")) and returns the search count as double value. This works fine.

When I try to use this field in issue search I get the results displayed but can not use it in search or while sorting issue by this field value.

Here the script:

import com.atlassian.jira.issue.Issue
import com.atlassian.jira.jql.parser.JqlQueryParser
import com.atlassian.jira.component.ComponentAccessor
import com.atlassian.jira.bc.issue.search.DefaultSearchService
import com.atlassian.query.Query
import com.atlassian.jira.user.ApplicationUser

def jqlQueryParser = ComponentAccessor.getComponent(JqlQueryParser)
def searchService = ComponentAccessor.getComponent(DefaultSearchService)
def ApplicationUser user = ComponentAccessor.jiraAuthenticationContext.getLoggedInUser()

if (user != null && user.isActive()) {
// edit this query to suit
Query query = jqlQueryParser.parseQuery("type = Testfall AND issue in requirementTests(" + issue.key + ")")
if (searchService.searchCount(user, query).doubleValue()) {
return searchService.searchCount(user, query).doubleValue()
} else {
return 0
}
}

 

Is there anyone who can help me?

 

Best Regards

Lubi

 

2 answers

I have updated Scriptrunner to Version 6.13.1 but sorting and searching does still not work. What can I do else?

I'd raise this directly with the SR support team.

The numeric scripted field I've got that returns like yours does works fine when the number-range searcher is selected for it.  Although I have a nagging doubt it returns a long rather than a double, I can't imagine that would be the answer.

0 votes

In the script settings, is the output template set to be a number field?

When you go to Custom fields -> Your scripted field -> Edit, what do you have set for a "searcher" for it?

Hi Nic,

i already tried number search for exact number and number range.

Regards

Lubi

Did you re-index after changing the searcher?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Confluence

An update on Confluence Cloud customer feedback – June 2022

Hi everyone, We’re always looking at how to improve Confluence and customer feedback plays an important role in making sure we're investing in the areas that will bring the most value to the most c...

183 views 1 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you