Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

ScriptRunner-@WithPlugin,Requested plugin com.decadis.jira.xchart was not installed/enabled

How can I solve this problem?

I use the ScriptRunner to run a script, 1 error appear

import com.onresolve.scriptrunner.runner.customisers.WithPlugin;

//import com.decadis.jira.xchart.api.ChartParam;
//import com.decadis.jira.xchart.api.model.Period
//import com.decadis.jira.xchart.api.util.DateUtils;


startup failed: General error during conversion: Requested plugin com.decadis.jira.xchart was not installed/enabled, compiling source unit Script516.groovy. java.lang.Exception: Requested plugin com.decadis.jira.xchart was not installed/enabled, compiling source unit

I`m authorised by jiraadmin, The plugin xChart has been installed in jira.

JIRA Version:8.2.1

1 answer

0 votes
Jack Nolddor [Sweet Bananas]
Marketplace Partner
Marketplace Partners provide apps and integrations available on the Atlassian Marketplace that extend the power of Atlassian products.
Feb 21, 2020

Hi chenzili,

I believe xChart plugin key is in fact "com.decadis.jira.xchart.xchart-core"


Could you please try this?




Hi Jack,

According to your suggestion, I have tried it, but new error appeard.

[groovy.lang.MissingPropertyException: No such property: ChartBuilder for class: Script547 at]


I check this vaviable in

It makes me puzzled

I run this script in the Script Console

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events